summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm106
1 files changed, 53 insertions, 53 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f1ef480c42..d167269c24 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -357,7 +357,7 @@ provided.")
(define-public editres
(package
(name "editres")
- (version "1.0.6")
+ (version "1.0.7")
(source
(origin
(method url-fetch)
@@ -367,7 +367,7 @@ provided.")
".tar.bz2"))
(sha256
(base32
- "1w2d5hb5pw9ii2jlf4yjlp899402zfwc8hdkpdr3i1fy1cjd2riv"))))
+ "04awfwmy3f9f0bchidc4ssbgrbicn5gzasg3jydpfnp5513d76h8"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -918,7 +918,7 @@ rendering commands to the X server.")
(define-public iceauth
(package
(name "iceauth")
- (version "1.0.7")
+ (version "1.0.8")
(source
(origin
(method url-fetch)
@@ -928,7 +928,7 @@ rendering commands to the X server.")
".tar.bz2"))
(sha256
(base32
- "02izdyzhwpgiyjd8brzilwvwnfr72ncjb6mzz3y1icwrxqnsy5hj"))))
+ "1ik0mdidmyvy48hn8p2hwvf3535rf3m96hhf0mvcqrbj44x23vp6"))))
(build-system gnu-build-system)
(inputs
`(("libice" ,libice)))
@@ -1558,7 +1558,7 @@ input from UTF-8 into the locale's encoding.")
(define-public mkfontscale
(package
(name "mkfontscale")
- (version "1.1.2")
+ (version "1.1.3")
(source
(origin
(method url-fetch)
@@ -1568,7 +1568,7 @@ input from UTF-8 into the locale's encoding.")
".tar.bz2"))
(sha256
(base32
- "081z8lwh9c1gyrx3ad12whnpv3jpfbqsc366mswpfm48mwl54vcc"))))
+ "0siag28jpm8hj62bgjvw81sjfgrc7vcy2h7127bl4iazxrlxz60y"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)
@@ -2001,7 +2001,7 @@ information used in connecting to the X server.")
(define-public xbacklight
(package
(name "xbacklight")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
@@ -2011,7 +2011,7 @@ information used in connecting to the X server.")
".tar.bz2"))
(sha256
(base32
- "0arnd1j8vzhzmw72mqhjjcb2qwcbs9qphsy3ps593ajyld8wzxhp"))))
+ "0pmzaz4kp38qv2lqiw5rnqhwzmwrq65m1x5j001mmv99wh9isnk1"))))
(build-system gnu-build-system)
(inputs
`(("libxcb" ,libxcb)
@@ -2031,7 +2031,7 @@ the same way.")
(define-public xbitmaps
(package
(name "xbitmaps")
- (version "1.1.1")
+ (version "1.1.2")
(source
(origin
(method url-fetch)
@@ -2041,7 +2041,7 @@ the same way.")
".tar.bz2"))
(sha256
(base32
- "178ym90kwidia6nas4qr5n5yqh698vv8r02js0r4vg3b6lsb0w9n"))))
+ "1vh73sc13s7w5r6gnc6irca56s7998bja7wgdivkfn8jccawgw5r"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
@@ -2175,7 +2175,7 @@ X11 Inter-Client Communication Conventions Manual (ICCCM).")
(define-public xcursor-themes
(package
(name "xcursor-themes")
- (version "1.0.4")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
@@ -2185,7 +2185,7 @@ X11 Inter-Client Communication Conventions Manual (ICCCM).")
".tar.bz2"))
(sha256
(base32
- "11mv661nj1p22sqkv87ryj2lcx4m68a04b0rs6iqh3fzp42jrzg3"))))
+ "0whjiq6d5z4z75zh37pji6llfcyrg6q3mg9zx5zqyncnj39q30xf"))))
(build-system gnu-build-system)
(inputs
`(("libxcursor" ,libxcursor)
@@ -2274,7 +2274,7 @@ available.")
(define-public xdriinfo
(package
(name "xdriinfo")
- (version "1.0.5")
+ (version "1.0.6")
(source
(origin
(method url-fetch)
@@ -2284,7 +2284,7 @@ available.")
".tar.bz2"))
(sha256
(base32
- "0681d0y8liqakkpz7mmsf689jcxrvs5291r20qi78mc9xxk3gfjc"))))
+ "0lcx8h3zd11m4w8wf7dyp89826d437iz78cyrix436bqx31x5k6r"))))
(build-system gnu-build-system)
(inputs
`(("mesa" ,mesa)
@@ -3843,7 +3843,7 @@ can be combined together using the 'rules' component of this database.")
(define-public xkill
(package
(name "xkill")
- (version "1.0.4")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
@@ -3853,7 +3853,7 @@ can be combined together using the 'rules' component of this database.")
".tar.bz2"))
(sha256
(base32
- "0bl1ky8ps9jg842j4mnmf4zbx8nkvk0h77w7bqjlpwij9wq2mvw8"))))
+ "0szzd9nzn0ybkhnfyizb876irwnjsnb78rcaxx6prb71jmmbpw65"))))
(build-system gnu-build-system)
(inputs
`(("libxmu" ,libxmu)
@@ -3898,7 +3898,7 @@ programs that have displayed undesired windows on a user's screen.")
(define-public xlsclients
(package
(name "xlsclients")
- (version "1.1.3")
+ (version "1.1.4")
(source
(origin
(method url-fetch)
@@ -3908,7 +3908,7 @@ programs that have displayed undesired windows on a user's screen.")
".tar.bz2"))
(sha256
(base32
- "0g9x7rrggs741x9xwvv1k9qayma980d88nhdqw7j3pn3qvy6d5jx"))))
+ "1h8931sn34mcip6vpi4v7hdmr1r58gkbw4s2p97w98kykks2lgvp"))))
(build-system gnu-build-system)
(inputs
`(("libxcb" ,libxcb)))
@@ -3925,7 +3925,7 @@ running on X server.")
(define-public xlsfonts
(package
(name "xlsfonts")
- (version "1.0.5")
+ (version "1.0.6")
(source
(origin
(method url-fetch)
@@ -3935,7 +3935,7 @@ running on X server.")
".tar.bz2"))
(sha256
(base32
- "1yi774g6r1kafsbnxbkrwyndd3i60362ck1fps9ywz076pn5naa0"))))
+ "0s6kxgv78chkwsqmhw929f4pf91gq63f4yvixxnan1h00cx0pf49"))))
(build-system gnu-build-system)
(inputs
`(("xproto" ,xproto)
@@ -3952,7 +3952,7 @@ protocol.")
(define-public xfontsel
(package
(name "xfontsel")
- (version "1.0.5")
+ (version "1.0.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3960,7 +3960,7 @@ protocol.")
version ".tar.bz2"))
(sha256
(base32
- "1grir464hy52a71r3mpm9mzvkf7nwr3vk0b1vc27pd3gp588a38p"))))
+ "0700lf6hx7dg88wq1yll7zjvf9gbwh06xff20yffkxb289y0pai5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -4084,7 +4084,7 @@ refers to the included common xorg.css stylesheet.")
(define-public xpr
(package
(name "xpr")
- (version "1.0.4")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
@@ -4094,7 +4094,7 @@ refers to the included common xorg.css stylesheet.")
".tar.bz2"))
(sha256
(base32
- "1dbcv26w2yand2qy7b3h5rbvw1mdmdd57jw88v53sgdr3vrqvngy"))))
+ "07qy9lwjvxighcmg6qvjkgagad3wwvidrfx0jz85lgynz3qy0dmr"))))
(build-system gnu-build-system)
(inputs
`(("xproto" ,xproto)
@@ -4113,7 +4113,7 @@ it for output on various types of printers.")
(define-public xprop
(package
(name "xprop")
- (version "1.2.2")
+ (version "1.2.3")
(source
(origin
(method url-fetch)
@@ -4123,7 +4123,7 @@ it for output on various types of printers.")
".tar.bz2"))
(sha256
(base32
- "1ilvhqfjcg6f1hqahjkp8qaay9rhvmv2blvj3w9asraq0aqqivlv"))))
+ "06sjgahjiz85v0k0pmv5x05chc591xynl5ah1bqzz1bdr0lgnanj"))))
(build-system gnu-build-system)
(inputs
`(("xproto" ,xproto)
@@ -4170,7 +4170,7 @@ and Reflect (RandR) extension.")
(define-public xrdb
(package
(name "xrdb")
- (version "1.1.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
@@ -4180,7 +4180,7 @@ and Reflect (RandR) extension.")
".tar.bz2"))
(sha256
(base32
- "0nsnr90wazcdd50nc5dqswy0bmq6qcj14nnrhyi7rln9pxmpp0kk"))))
+ "1dqp486nd5sagbg572kl0k839nwvpqnb7jvppyb7jj5vrpkss8rd"))))
(build-system gnu-build-system)
(inputs
`(("libxmu" ,libxmu)
@@ -4201,7 +4201,7 @@ file.")
(define-public xrefresh
(package
(name "xrefresh")
- (version "1.0.5")
+ (version "1.0.6")
(source
(origin
(method url-fetch)
@@ -4211,7 +4211,7 @@ file.")
".tar.bz2"))
(sha256
(base32
- "1mlinwgvql6s1rbf46yckbfr9j22d3c3z7jx3n6ix7ca18dnf4rj"))))
+ "0lv3rlshh7s0z3aqx5ahnnf8cl082m934bk7gv881mz8nydznz98"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)))
@@ -4229,7 +4229,7 @@ up your screen.")
(define-public xset
(package
(name "xset")
- (version "1.2.3")
+ (version "1.2.4")
(source
(origin
(method url-fetch)
@@ -4239,7 +4239,7 @@ up your screen.")
".tar.bz2"))
(sha256
(base32
- "0qw0iic27bz3yz2wynf1gxs70hhkcf9c4jrv7zhlg1mq57xz90j3"))))
+ "0my987wjvra7l92ry6q44ky383yg3phzxhdbn3lqhapm1ll9bzg4"))))
(build-system gnu-build-system)
(inputs
`(("xproto" ,xproto)
@@ -4258,7 +4258,7 @@ up your screen.")
(define-public xsetroot
(package
(name "xsetroot")
- (version "1.1.1")
+ (version "1.1.2")
(source
(origin
(method url-fetch)
@@ -4268,7 +4268,7 @@ up your screen.")
".tar.bz2"))
(sha256
(base32
- "1nf3ii31m1knimbidaaym8p61fq3blv8rrdr2775yhcclym5s8ds"))))
+ "0z21mqvmdl6rl63q77479wgkfygnll57liza1i3va7sr4fx45i0h"))))
(build-system gnu-build-system)
(inputs
`(("libxmu" ,libxmu)
@@ -4343,7 +4343,7 @@ extension.")
(define-public xwd
(package
(name "xwd")
- (version "1.0.6")
+ (version "1.0.7")
(source
(origin
(method url-fetch)
@@ -4353,7 +4353,7 @@ extension.")
".tar.bz2"))
(sha256
(base32
- "0ybx48agdvjp9lgwvcw79r1x6jbqbyl3fliy3i5xwy4d4si9dcrv"))))
+ "1537i8q8pgf0sjklakzfvjwrq5b246qjywrx9ll8xfg0p6w1as6d"))))
(build-system gnu-build-system)
(inputs
`(("libxt" ,libxt)
@@ -4376,7 +4376,7 @@ dump and twice whenthe dump is completed.")
(define-public xwininfo
(package
(name "xwininfo")
- (version "1.1.3")
+ (version "1.1.4")
(source
(origin
(method url-fetch)
@@ -4386,7 +4386,7 @@ dump and twice whenthe dump is completed.")
".tar.bz2"))
(sha256
(base32
- "1y1zn8ijqslb5lfpbq4bb78kllhch8in98ps7n8fg3dxjpmb13i1"))))
+ "00avrpw4h5mr1klp41lv2j4dmq465v6l5kb5bhm4k5ml8sm9i543"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -4404,7 +4404,7 @@ Various information is displayed depending on which options are selected.")
(define-public xwud
(package
(name "xwud")
- (version "1.0.4")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
@@ -4414,7 +4414,7 @@ Various information is displayed depending on which options are selected.")
".tar.bz2"))
(sha256
(base32
- "1ggql6maivah58kwsh3z9x1hvzxm1a8888xx4s78cl77ryfa1cyn"))))
+ "1a8hdgy40smvblnh3s9f0vkqckl68nmivx7d48zk34m8z18p16cr"))))
(build-system gnu-build-system)
(inputs
`(("xproto" ,xproto)
@@ -4761,14 +4761,14 @@ common definitions and porting layer.")
(define-public xorgproto
(package
(name "xorgproto")
- (version "2018.3")
+ (version "2018.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/proto/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "1rdhw28n1gp7yylwia41jhih66gfx75nxgrmi2ggglzvzqhwr0x8"))))
+ "180mqkp70i44rkmj430pmn9idssvffrgv4y5h19fm698a7h8bs7y"))))
(build-system gnu-build-system)
(propagated-inputs
;; To get util-macros in (almost?) all package inputs.
@@ -5409,17 +5409,17 @@ Intrinsics (Xt) Library.")
(define-public twm
(package
(name "twm")
- (version "1.0.9")
+ (version "1.0.10")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/app/" name "-"
version
- ".tar.gz"))
+ ".tar.bz2"))
(sha256
(base32
- "1s1r00x8add3f27xjqxg6q7mwplwrb72gakbh4y6j052as25wchw"))))
+ "1ms5cj1w3g26zg6bxdv1j9hl0pxr4300qnv003cz1q3cl7ffljb4"))))
(build-system gnu-build-system)
(inputs
`(("libxt" ,libxt)
@@ -5638,14 +5638,14 @@ The XCB util-wm module provides the following libraries:
(define-public xinit
(package
(name "xinit")
- (version "1.3.4")
+ (version "1.4.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/app/xinit-"
version ".tar.bz2"))
(sha256
(base32
- "1cq2g469mb2cfgr8k57960yrn90bl33vfqri4pdh2zm0jxrqvn3m"))))
+ "1vw2wlg74ig52naw0cha3pgzcwwk25l834j42cg8m5zmybp3a213"))))
(build-system gnu-build-system)
(inputs
`(("xproto" ,xproto)
@@ -5727,7 +5727,7 @@ of an X11 screen.")
(define-public xmessage
(package
(name "xmessage")
- (version "1.0.4")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
@@ -5737,7 +5737,7 @@ of an X11 screen.")
".tar.gz"))
(sha256
(base32
- "1jmcac1xbwplbxfl75sr6w3zqhx1khpdzlqippjsr31cjp1rjc48"))))
+ "0sw0b0cbrjl44brw7qi1jkm61xd7a1lpj04418c6iqk6mf83llwr"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -5801,7 +5801,7 @@ programs that cannot use the window system directly.")
(define-public perl-x11-xcb
(package
(name "perl-x11-xcb")
- (version "0.16")
+ (version "0.17")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5809,7 +5809,7 @@ programs that cannot use the window system directly.")
"X11-XCB-" version ".tar.gz"))
(sha256
(base32
- "14mnvr1001py2z1n43l18yaw0plwvjg5pcsyc7k81sa0amw8ahzw"))))
+ "12qyf98s5hbybmh0mblpz50c00i68srq73w5rw31m2dhclj8n96q"))))
(build-system perl-build-system)
(arguments
'(;; Disable parallel build to prevent a race condition.
@@ -5932,7 +5932,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "2.2.4")
+ (version "2.2.5")
(source
(origin
(method url-fetch)
@@ -5940,7 +5940,7 @@ basic eye-candy effects.")
version ".tar.xz"))
(sha256
(base32
- "0v8yflvisk94bfj0zg4ggdfwrig0f3ss9kjnws3zflsr33cb2hxy"))))
+ "1q2l00nc3bgwlhjzkbk4a8x2l8z9w1799yn31icsx5hrgh98a1js"))))
(build-system python-build-system)
(inputs `(("ffmpeg" ,ffmpeg)
("flac" ,flac)