summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm72
1 files changed, 37 insertions, 35 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f3ae2cd03d..3134fae4a2 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 John Darrington <jmd@gnu.org>
@@ -104,23 +104,21 @@
;; License: x11, see COPYING
(origin
(method url-fetch)
- (uri "mirror://xorg/individual/util/xorg-cf-files-1.0.5.tar.bz2")
+ (uri "mirror://xorg/individual/util/xorg-cf-files-1.0.6.tar.bz2")
(sha256
- (base32
- "1m3ypq0xcy46ghxc0svl1rbhpy3zvgmy0aa2mn7w7v7d8d8bh8zd"))))
+ (base32 "0kckng0zs1viz0nr84rdl6dswgip7ndn4pnh5nfwnviwpsfmmksd"))))
(define-public imake
(package
(name "imake")
- (version "1.0.7")
+ (version "1.0.8")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/util/imake-"
version ".tar.bz2"))
(sha256
- (base32
- "0zpk8p044jh14bis838shbf4100bjg7mccd7bq54glpsq552q339"))))
+ (base32 "00m7l90ws72k1qm101sd2rx92ckd50cszyng5d4dd77jncbf9lmq"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -1110,7 +1108,7 @@ synchronization between the X server and direct-rendering clients.")
(define-public libfs
(package
(name "libfs")
- (version "1.0.7")
+ (version "1.0.8")
(source
(origin
(method url-fetch)
@@ -1119,8 +1117,7 @@ synchronization between the X server and direct-rendering clients.")
version
".tar.bz2"))
(sha256
- (base32
- "1wy4km3qwwajbyl8y9pka0zwizn7d9pfiyjgzba02x3a083lr79f"))))
+ (base32 "03xxyvpfa3rhqcld4p2chkil482jn9cp80hj17jdybcv2hkkgqf8"))))
(build-system gnu-build-system)
(inputs
`(("xtrans" ,xtrans)
@@ -1500,25 +1497,22 @@ treat it as part of their software base when porting.")
(define-public libxxf86dga
(package
(name "libxxf86dga")
- (version "1.1.4")
+ (version "1.1.5")
(source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/lib/libXxf86dga-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "0zn7aqj8x0951d8zb2h2andldvwkzbsc4cs7q023g6nzq6vd9v4f"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://xorg/individual/lib/"
+ "libXxf86dga-" version ".tar.bz2"))
+ (sha256
+ (base32 "00vjvcdlc1sga251jkxn6gkxmx9h5n290ffxxpa40qbca1gvr61b"))))
(build-system gnu-build-system)
(propagated-inputs
- `(("xorgproto" ,xorgproto)))
+ `(("xorgproto" ,xorgproto)))
(inputs
- `(("libx11" ,libx11)
- ("libxext" ,libxext)))
+ `(("libx11" ,libx11)
+ ("libxext" ,libxext)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg XFree86-DGA library")
(description "Client library for the XFree86-DGA extension.")
@@ -1585,7 +1579,7 @@ input from UTF-8 into the locale's encoding.")
(define-public mkfontscale
(package
(name "mkfontscale")
- (version "1.1.3")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
@@ -1594,8 +1588,7 @@ input from UTF-8 into the locale's encoding.")
version
".tar.bz2"))
(sha256
- (base32
- "0siag28jpm8hj62bgjvw81sjfgrc7vcy2h7127bl4iazxrlxz60y"))))
+ (base32 "1gn423m0v1w98df7ni74zrj2rkhsapnqfzr8139l638kkyz7far8"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)
@@ -1970,7 +1963,7 @@ server.")
(define-public x11perf
(package
(name "x11perf")
- (version "1.6.0")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
@@ -1980,7 +1973,7 @@ server.")
".tar.bz2"))
(sha256
(base32
- "0lb716yfdb8f11h4cz93d1bapqdxf1xplsb21kbp4xclq7g9hw78"))))
+ "0d3wh6z6znwhfdiv0zaggfj0xgish98xa10yy76b9517zj7hnzhw"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -2624,14 +2617,14 @@ as USB mice.")
(define-public xf86-video-amdgpu
(package
(name "xf86-video-amdgpu")
- (version "19.0.0")
+ (version "19.0.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/driver/"
"xf86-video-amdgpu-" version ".tar.bz2"))
(sha256
- (base32 "0lag9jxd752ja7m7ngz3dmqffb5wbx4crdwjw74qx42m8xyi8dl8"))))
+ (base32 "1mf6s7i423b2xyl469kwnakrpp5fr41sm8hh7vli5jxdd8crg8da"))))
(build-system gnu-build-system)
(inputs `(("xorg-server" ,xorg-server)))
(native-inputs `(("pkg-config" ,pkg-config)))
@@ -2691,14 +2684,14 @@ X server.")
(define-public xf86-video-ati
(package
(name "xf86-video-ati")
- (version "19.0.0")
+ (version "19.0.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/driver/"
"xf86-video-ati-" version ".tar.bz2"))
(sha256
- (base32 "0mzl7yp3qkvankh22758sgpaw9mg6jxsfbg6wy0nxfw4i0qpv46x"))))
+ (base32 "1c31g5q5p3nk9nscwikh1vvfnhdwsxiw7j8v678nlm34hrfh3djw"))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
("xorgproto" ,xorgproto)
@@ -6009,7 +6002,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "2.4.3")
+ (version "2.5")
(source
(origin
(method url-fetch)
@@ -6017,7 +6010,7 @@ basic eye-candy effects.")
version ".tar.xz"))
(sha256
(base32
- "0pq2pzmv5fsafp50rzl9nb6ns08rl88fhgdqc2hh27dx7b8ka8n6"))))
+ "0q6c7ijgpp2wk6jlh0pzqki1w60i36wyl2zfwkg0gpdh40ypab3x"))))
(build-system python-build-system)
(inputs `(("ffmpeg" ,ffmpeg)
("flac" ,flac)
@@ -6375,6 +6368,15 @@ output.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'patch-file-names
+ (lambda _
+ ;; 'ckbcomp' calls out to 'cat' (!). Give it the right file
+ ;; name.
+ (substitute* '("Keyboard/ckbcomp")
+ (("\"cat ")
+ (string-append "\"" (which "cat")
+ " ")))
+ #t))
(add-before 'build 'make-doubled-bdfs
(lambda* (#:key inputs #:allow-other-keys)
(invoke "make" "-C" "Fonts"