summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index e14524a684..ad0e530c4b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -64,14 +64,14 @@
(define-public expat
(package
(name "expat")
- (version "2.2.5")
+ (version "2.2.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/expat/expat/"
version "/expat-" version ".tar.bz2"))
(sha256
(base32
- "1xpd78sp7m34jqrw5x13bz7kgz0n6aj15wn4zj4gfx3ypbpk5p6r"))))
+ "1wl1x93b5w457ddsdgj0lh7yjq4q6l7wfbgwhagkc8fm2qkkrd0p"))))
(build-system gnu-build-system)
(home-page "https://libexpat.github.io/")
(synopsis "Stream-oriented XML parser library written in C")
@@ -129,8 +129,23 @@ hierarchical form with variable field lengths.")
(base32
"0ci7is75bwqqw2p32vxvrk6ds51ik7qgx73m920rakv5jlayax0b"))))
(build-system gnu-build-system)
+ (outputs '("out" "static"))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'move-static-libs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((src (string-append (assoc-ref outputs "out") "/lib"))
+ (dst (string-append (assoc-ref outputs "static")
+ "/lib")))
+ (mkdir-p dst)
+ (for-each (lambda (ar)
+ (rename-file ar (string-append dst "/"
+ (basename ar))))
+ (find-files src "\\.a$"))
+ #t))))))
(home-page "http://www.xmlsoft.org/")
(synopsis "C parser for XML")
+ (inputs `(("xz" ,xz)))
(propagated-inputs `(("zlib" ,zlib))) ; libxml2.la says '-lz'.
(native-inputs `(("perl" ,perl)))
;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
@@ -151,6 +166,7 @@ project (but it is usable outside of the Gnome platform).")
(package/inherit libxml2
(name "python-libxml2")
(build-system python-build-system)
+ (outputs '("out"))
(arguments
`(;; XXX: Tests are specified in 'Makefile.am', but not in 'setup.py'.
#:tests? #f