summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index e42c58050d..e213fb6067 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages gnome)
#:use-module (gnu packages pdf)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages photo)
@@ -111,6 +112,8 @@ Xfce Desktop Environment.")
;; Run test-suite under a dbus session.
(setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
(string-append %output "/share"))
+ ;; For the missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0");
(zero? (system* "dbus-launch" "make" "check")))
(alist-delete 'check %standard-phases))))
(native-inputs
@@ -421,7 +424,19 @@ your system in categories, so you can quickly find and launch them.")
"/src/" name "-" version ".tar.bz2"))
(sha256
(base32
- "01kvbd09c06j20n155hracsgrq06rlmfgdywffjsvlwpn19m9j38"))))
+ "01kvbd09c06j20n155hracsgrq06rlmfgdywffjsvlwpn19m9j38"))
+ (patches
+ ;; See: https://bugzilla.xfce.org/show_bug.cgi?id=12282
+ (list (search-patch "xfce4-session-fix-xflock4.patch")))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "xfsm-shutdown-helper/main.c"
+ (("/sbin/shutdown -h now") "halt")
+ (("/sbin/shutdown -r now") "restart")
+ (("/usr/sbin/pm-suspend") "pm-suspend")
+ (("/usr/sbin/pm-hibernate") "pm-hibernate"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -431,6 +446,8 @@ your system in categories, so you can quickly find and launch them.")
("intltool" ,intltool)))
(inputs
`(("iceauth" ,iceauth)
+ ("upower" ,upower)
+ ("polkit" ,polkit)
("libsm" ,libsm)
("libwnck" ,libwnck-1)
("libxfce4ui" ,libxfce4ui)))