summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm85
1 files changed, 62 insertions, 23 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index dc74c9f59e..be082eef73 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -18,10 +18,11 @@
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marek Benc <dusxmt@gmx.com>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -155,14 +156,14 @@ avoiding password prompts when X11 forwarding has already been setup.")
(define-public libxkbcommon
(package
(name "libxkbcommon")
- (version "0.7.1")
+ (version "0.8.0")
(source (origin
(method url-fetch)
(uri (string-append "https://xkbcommon.org/download/" name "-"
version ".tar.xz"))
(sha256
(base32
- "12z6hih3n1r0asp2hzp9qsiwdfkfz46jwp06x8kprr0r5rfk0nds"))))
+ "0vgy84vfbig5bqznr137h5arjidnfwrxrdli0pxyn2jfn1fjcag8"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -529,7 +530,7 @@ selection's dimensions to stdout.")
(define-public maim
(package
(name "maim")
- (version "5.5")
+ (version "5.5.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -538,7 +539,7 @@ selection's dimensions to stdout.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "02blbimjdckbcb04crhv0k2vxnp3rcgskyq66sk0v13l2h52849v"))))
+ "1dvw0axnr9hhjg6zdcq9lwvaq0x7vrzlz00p8n3hj25qzsi4z5as"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; no "check" target
@@ -881,14 +882,15 @@ Escape key when Left Control is pressed and released on its own.")
(define-public libwacom
(package
(name "libwacom")
- (version "0.29")
+ (version "0.30")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/linuxwacom/libwacom/"
- name "-" version ".tar.bz2"))
+ (uri (string-append
+ "https://github.com/linuxwacom/libwacom/releases/download/"
+ name "-" version "/" name "-" version ".tar.bz2"))
(sha256
(base32
- "1diklgcjhmvcxi9p1ifp6wcnyr6k7z9jhrlzfhzjqd6zipk01slw"))))
+ "0n9294f2534qcgfry4n7vmr6vy49iqym0y74a88g1h0l0ml0hd2j"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -901,7 +903,7 @@ Escape key when Left Control is pressed and released on its own.")
;; libwacom includes header files that include GLib, and libinput uses
;; those header files.
`(("glib" ,glib)))
- (home-page "http://linuxwacom.sourceforge.net/")
+ (home-page "https://linuxwacom.github.io/")
(synopsis "Helper library for Wacom tablet settings")
(description
"Libwacom is a library to help implement Wacom tablet settings. It is
@@ -913,15 +915,16 @@ Wacom tablet applet.")
(define-public xf86-input-wacom
(package
(name "xf86-input-wacom")
- (version "0.36.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/linuxwacom/xf86-input-wacom/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32
- "1xi39hl8ddgj9m7m2k2ll2r3wh0k0aq45fvrsv43651bhz9cbrza"))))
+ (version "0.36.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/linuxwacom/xf86-input-wacom/releases/download/"
+ name "-" version "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "029y8varbricba2dzhzhy0ndd7lbfif411ca8c3wxzni9qmbj1ij"))))
(arguments
`(#:configure-flags
(list (string-append "--with-sdkdir="
@@ -939,7 +942,7 @@ Wacom tablet applet.")
("libxinerama" ,libxinerama)
("libxi" ,libxi)
("eudev" ,eudev)))
- (home-page "http://linuxwacom.sourceforge.net/")
+ (home-page "https://linuxwacom.github.io/")
(synopsis "Wacom input driver for X")
(description
"The xf86-input-wacom driver is the wacom-specific X11 input driver for
@@ -949,7 +952,7 @@ the X.Org X Server version 1.7 and later (X11R7.5 or later).")
(define-public redshift
(package
(name "redshift")
- (version "1.11")
+ (version "1.12")
(source
(origin
(method url-fetch)
@@ -959,7 +962,7 @@ the X.Org X Server version 1.7 and later (X11R7.5 or later).")
"/redshift-" version ".tar.xz"))
(sha256
(base32
- "0ngkwj7rg8nfk806w0sg443w6wjr91xdc0zisqfm5h2i77wm1qqh"))))
+ "1fi27b73x85qqar526dbd33av7mahca2ykaqwr7siqiw1qqcby6j"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -969,7 +972,7 @@ the X.Org X Server version 1.7 and later (X11R7.5 or later).")
("libx11" ,libx11)
("libxcb" ,libxcb)
("libxxf86vm" ,libxxf86vm)
- ("glib" ,glib))) ;for Geoclue2 support
+ ("glib" ,glib))) ; for Geoclue2 support
(home-page "https://github.com/jonls/redshift")
(synopsis "Adjust the color temperature of your screen")
(description
@@ -1435,3 +1438,39 @@ with black color on a white background (colors are configurable on the
commandline).")
(home-page "https://www.joachim-breitner.de/projects#screen-message")
(license license:gpl2+)))
+
+(define-public xss-lock
+ ;; xss-lock does not seem to be maintained any longer, but the last commits
+ ;; fix important issues so we package them.
+ (let ((version "0.3.0")
+ (revision "1")
+ (commit "1e158fb20108058dbd62bd51d8e8c003c0a48717"))
+ (package
+ (name "xss-lock")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/raymonad/xss-lock.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10hx7k7ga8g08akwz8qrsvj8iqr5nd4siiva6sjx789jvf0sak7r"))))
+ (build-system cmake-build-system)
+ (inputs `(("glib" ,glib)
+ ("xcb-util" ,xcb-util)))
+ (native-inputs
+ `(("python-docutils" ,python-docutils)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f))
+ (synopsis "Use external screen locker on events")
+ (description "@code{xss-lock} listens to X signals to fire up a
+user-defined screensaver. In effect this allows to automatically lock the
+screen when closing a laptop lid or after a period of user inactivity (as set
+with @code{xset s TIMEOUT}). The notifier command, if specified, is executed
+first. Additionally, xss-lock uses the inhibition logic to lock the screen
+before the system goes to sleep.")
+ (home-page "https://bitbucket.org/raymonad/xss-lock")
+ (license license:expat))))