summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm33
1 files changed, 28 insertions, 5 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 3beaa97c90..87d14e20a4 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -401,7 +401,7 @@ tracking.")
(inputs
`(("libx11" ,libx11)
("xcb-util" ,xcb-util)))
- (home-page "http://www.freedesktop.org/wiki/Software/startup-notification/")
+ (home-page "https://www.freedesktop.org/wiki/Software/startup-notification/")
(synopsis "Application startup notification and feedback library")
(description
"Startup-notification contains a reference implementation of the startup
@@ -1096,7 +1096,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
(define-public rofi
(package
(name "rofi")
- (version "1.4.2")
+ (version "1.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/DaveDavenport/rofi/"
@@ -1104,7 +1104,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
version "/rofi-" version ".tar.xz"))
(sha256
(base32
- "1129cbg76g56c6ckzj5y5haf92jxhx3b71cr3qmhrb0n8g4gi38s"))))
+ "0li2hl55sxzdpbxxiwgxsvkhyy6bh8qd2j1r8xh8y6q8a318zsz9"))))
(build-system gnu-build-system)
(inputs
`(("pango" ,pango)
@@ -1121,6 +1121,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
`(("bison" ,bison)
("check" ,check)
("flex" ,flex)
+ ("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(arguments
`(#:parallel-tests? #f ; May fail in some circumstances.
@@ -1131,8 +1132,30 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
(substitute* '("test/helper-expand.c")
(("~root") "/root")
(("~") "")
- (("g_get_home_dir \\(\\)") "\"/\"")))))))
- (home-page "https://davedavenport.github.io/rofi/")
+ (("g_get_home_dir \\(\\)") "\"/\""))
+ #t))
+ (add-before 'check 'add-missing-configuration-files
+ (lambda _
+ ;; These files are missing in the 1.5.0 release, causing a test
+ ;; failure: <https://github.com/DaveDavenport/rofi/issues/782>.
+ (with-directory-excursion "subprojects/libnkutils/tests"
+ (mkdir "gtk-3.0")
+ (call-with-output-file "gtk-3.0/settings.ini"
+ (lambda (port)
+ (format port "[Settings]
+gtk-double-click-time = 300
+gtk-cursor-theme-name = gnome
+")))
+ (mkdir "gtk-4.0")
+ (call-with-output-file "gtk-4.0/settings.ini"
+ (lambda (port)
+ (format port "[Settings]
+gtk-double-click-time = 300
+gtk-icon-theme-name = nothing-like-this-theme
+gtk-enable-primary-paste = true
+")))
+ #t))))))
+ (home-page "https://github.com/DaveDavenport/rofi")
(synopsis "Application launcher")
(description "Rofi is a minimalist application launcher. It memorizes which
applications you regularly use and also allows you to search for an application