summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm71
1 files changed, 51 insertions, 20 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 6713560c5f..7ae8e4b7f8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -9,9 +9,10 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 ng0 <ng0@libertad.pw>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
+;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,7 @@
#:use-module (gnu packages docbook)
#:use-module (gnu packages image)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages python)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libevent)
#:use-module (gnu packages fribidi)
@@ -122,14 +124,14 @@ the leaves of a full binary tree.")
(define-public i3status
(package
(name "i3status")
- (version "2.10")
+ (version "2.11")
(source (origin
(method url-fetch)
(uri (string-append "https://i3wm.org/i3status/i3status-"
version ".tar.bz2"))
(sha256
(base32
- "1497dsvb32z9xljmxz95dnyvsbayn188ilm3l4ys8m5h25vd1xfs"))))
+ "0pwcy599fw8by1a1sf91crkqba7679qhvhbacpmhis8c1xrpxnwq"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
@@ -319,7 +321,7 @@ prompt.")
(define-public xmonad
(package
(name "xmonad")
- (version "0.11.1")
+ (version "0.12")
(synopsis "Tiling window manager")
(source (origin
(method url-fetch)
@@ -327,22 +329,15 @@ prompt.")
name "-" version ".tar.gz"))
(sha256
(base32
- "1pfjssamiwpwjp1qqkm9m9p9s35pv381m0cwg6jxg0ppglibzq1r"))
- (modules '((guix build utils)))
- (snippet
- ;; Here we update the constraints on the utf8-string package in
- ;; the Cabal file. We allow a newer version which is compatible
- ;; with GHC 7.10.2. The same change is applied on Hackage. See
- ;; <https://hackage.haskell.org/package/xmonad-0.11.1/revisions/>.
- '(substitute* "xmonad.cabal"
- (("utf8-string >= 0.3 && < 0.4")
- "utf8-string >= 0.3 && < 1.1")))))
+ "1mzx3p17ppgmi30q3phaj58x6kxn73pbbkn9v9gzgmd8skdlkxp8"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-mtl" ,ghc-mtl)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
- ("ghc-x11" ,ghc-x11)))
+ `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-setlocale" ,ghc-setlocale)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-x11" ,ghc-x11)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -375,7 +370,7 @@ tiled on several screens.")
(define-public ghc-xmonad-contrib
(package
(name "ghc-xmonad-contrib")
- (version "0.11.4")
+ (version "0.12")
(source
(origin
(method url-fetch)
@@ -383,7 +378,7 @@ tiled on several screens.")
"xmonad-contrib-" version ".tar.gz"))
(sha256
(base32
- "1g5cw9vvnfbiyi599fngk02zlmdhrf82x0bndhypkn6kybab6yd3"))))
+ "04gk449dxwmimmb6y2d2hvvmv91r91xlj879qzlyq0mcf723278k"))))
(build-system haskell-build-system)
(propagated-inputs
`(("ghc-mtl" ,ghc-mtl)
@@ -601,3 +596,39 @@ experience.")
dynamic and extensible using the Lua programming language.")
(license license:gpl2+)
(home-page "https://awesome.naquadah.org/")))
+
+(define-public menumaker
+ (package
+ (name "menumaker")
+ (version "0.99.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/menumaker/"
+ "menumaker-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mm4cvg3kphkkd8nwrhcg6d9nm5ar7mgc0wf6fxk6zck1l7xn8ky"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("python" ,python)))
+ (synopsis "Heuristics-driven menu generator")
+ (description
+ "MenuMaker is a menu generation utility for a number of X window
+managers and desktop environments. It is capable of finding lots of
+installed programs and generating a root menu consistent across all
+supported window managers, so one will get (almost) the same menu in
+all of them. Currently supported window managers include:
+
+@enumerate
+@item BlackBox
+@item Deskmenu
+@item FluxBox
+@item IceWM
+@item OpenBox
+@item PekWM
+@item WindowMaker
+@item XFCE
+@end enumerate\n")
+ (home-page "http://menumaker.sourceforge.net/")
+ (license license:bsd-2)))