summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm20
1 files changed, 2 insertions, 18 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8fe94e28b4..02dfa0143f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -89,7 +89,6 @@
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages logging)
#:use-module (gnu packages serialization)
- #:use-module (gnu packages commencement) ; TODO remove when default gcc version >=7
#:use-module (guix download)
#:use-module (guix git-download))
@@ -596,10 +595,8 @@ tiled on several screens.")
`(("ghc-hinotify" ,ghc-hinotify)
("ghc-http" ,ghc-http)
("ghc-iwlib" ,ghc-iwlib)
- ("ghc-parsec" ,ghc-parsec)
("ghc-parsec-numbers" ,ghc-parsec-numbers)
("ghc-regex-compat" ,ghc-regex-compat)
- ("ghc-stm" ,ghc-stm)
("ghc-x11-xft" ,ghc-x11-xft)
("libxpm" ,libxpm)))
(arguments
@@ -1076,10 +1073,6 @@ project derived from the original Calm Window Manager.")
("glibmm" ,glibmm)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (arguments
- `(#:configure-flags (list
- (string-append "--prefix=" %output)
- "CXXFLAGS=-std=c++11")))
(home-page "http://projects.l3ib.org/nitrogen/")
(synopsis "Background browser and setter for X windows")
(description
@@ -1337,15 +1330,7 @@ modules for building a Wayland compositor.")
(build-system meson-build-system)
(arguments
`(#:configure-flags
- (list (string-append "-Dout=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; TODO remove when issue #30756 is resolved
- (add-before 'configure 'fix-gcc
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t)))))
+ (list (string-append "-Dout=" (assoc-ref %outputs "out")))))
(inputs `(("fmt" ,fmt)
("gtkmm" ,gtkmm)
("jsoncpp" ,jsoncpp)
@@ -1356,8 +1341,7 @@ modules for building a Wayland compositor.")
("pulseaudio" ,pulseaudio)
("spdlog" ,spdlog)
("wayland" ,wayland)))
- (native-inputs `(("gcc-toolchain" ,gcc-toolchain-7) ; TODO remove when default gcc version >=7
- ("glib:bin" ,glib "bin")
+ (native-inputs `(("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)
("wayland-protocols" ,wayland-protocols)))
(home-page "https://github.com/Alexays/Waybar")