summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 3169c7d15a..bda0fc6ba2 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -165,6 +165,13 @@ engine that uses Wayland for graphics output.")
"/xml/dtd/docbook/docbookx.dtd"))))
(find-files "Source" "\\.sgml$"))
#t))
+ (add-after 'unpack 'embed-absolute-wpebackend-reference
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((wpebackend-fdo (assoc-ref inputs "wpebackend-fdo")))
+ (substitute* "Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp"
+ (("libWPEBackend-fdo-([\\.0-9]+)\\.so" all version)
+ (string-append wpebackend-fdo "/lib/" all)))
+ #t)))
(add-after 'install 'move-doc-files
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))