summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 25 insertions, 5 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 66183273e6..7baee03185 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1029,6 +1029,13 @@ to perl-code, for faster generation of access_log lines.")
(base32
"02afhlrdq5hh5g8b32fa79fqq5i76qzwfqqvfi9zi57h31szl536"))))
(build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ ;; Fix the build with Perl 5.26.0. Try removing this phase for later
+ ;; versions of perl-authen-sasl.
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
(propagated-inputs
`(("perl-digest-hmac" ,perl-digest-hmac)
("perl-gssapi" ,perl-gssapi)))
@@ -1973,7 +1980,11 @@ with Encode::decode(locale => $string).")
(build-system perl-build-system)
(arguments
;; Tests expect to query files at http://stupidfool.org/perl/feeds/
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
(inputs
`(("perl-class-errorhandler" ,perl-class-errorhandler)
("perl-html-parser" ,perl-html-parser)
@@ -2161,15 +2172,15 @@ in tables within an HTML document, either as text or encoded element trees.")
(define-public perl-html-tree
(package
(name "perl-html-tree")
- (version "5.03")
+ (version "5.06")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/C/CJ/CJM/"
+ (uri (string-append "mirror://cpan/authors/id/K/KE/KENTNL/"
"HTML-Tree-" version ".tar.gz"))
(sha256
(base32
- "13qlqbpixw470gnck0xgny8hyjj576m8y24bba2p9ai2lvy76vbx"))))
+ "0vjk4xrybjqs511qrh9cymhpbg9m3jjqr52qr035k6nzrccyndlw"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)
@@ -2508,7 +2519,16 @@ environment from an HTTP::Request.")
(arguments
;; See the discussion of a related tests issue at
;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00346.html
- `(#:tests? #f))
+ `(#:tests? #f
+
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t)))))
(home-page "http://search.cpan.org/dist/HTTP-Server-Simple")
(synopsis "Lightweight HTTP server")
(description "HTTP::Server::Simple is a simple standalone HTTP daemon with