summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm54
1 files changed, 26 insertions, 28 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d04e5310bf..6cfe8fb1e9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
-;;; Copyright © 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
@@ -414,12 +414,7 @@ APIs.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests included
- #:make-flags (list "CC=gcc")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vif")))))))
+ #:make-flags (list "CC=gcc")))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -544,7 +539,8 @@ data.")
;; Don't try to build with -Werror.
(substitute* (find-files "." "Makefile\\.in")
- (("-Werror") ""))))))
+ (("-Werror") ""))
+ #t))))
(build-system gnu-build-system)
(arguments '(#:parallel-build? #f
#:parallel-tests? #f))
@@ -580,7 +576,8 @@ It aims to conform to RFC 7159.")
;; Don't try to build with -Werror.
(substitute* (find-files "." "Makefile\\.in")
- (("-Werror") ""))))))))
+ (("-Werror") ""))
+ #t))))))
(define-public qjson
(package
@@ -854,7 +851,7 @@ UTS#46.")
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
+ (replace 'bootstrap
(lambda* (#:key inputs #:allow-other-keys)
;; configure.in and Makefile.am aren't in the root of the
;; source tree.
@@ -2735,16 +2732,18 @@ used by the HTTP protocol (and then some more).")
(define-public perl-http-message
(package
(name "perl-http-message")
- (version "6.11")
+ (version "6.15")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/E/ET/ETHER/HTTP-Message-"
+ "mirror://cpan/authors/id/O/OA/OALDERS/HTTP-Message-"
version ".tar.gz"))
(sha256
(base32
- "06yq6cjx4vzl4if4ykap77xsrrd8aa7ish90k7cqi8g6g83nicz7"))))
+ "11fbvisyvi6bw8z9iq9fm9mraf69qyds09fblhl9gyvg7ccll93v"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-try-tiny" ,perl-try-tiny)))
(propagated-inputs
`(("perl-encode-locale" ,perl-encode-locale)
("perl-http-date" ,perl-http-date)
@@ -4033,11 +4032,7 @@ and vice-versa.")
"1bgg2kbj311pqdzw2v33za7k66g1rv44kkvvnz2gnpaasi9k0ii8"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; tests require bundling googletest sources
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _ (zero? (system* "sh" "autogen.sh")))))))
+ `(#:tests? #f)) ;tests require bundling googletest sources
;; The release tarball lacks the generated files.
(native-inputs
`(("autoconf" ,autoconf)
@@ -4845,10 +4840,11 @@ config files---you only have to specify the www root.")
(base32
"1w84y61f3ldg2f28q6qlyr1scn3mcx0bsbq3i5xi5w193wh3xa2q"))
(modules '((guix build utils)))
- (snippet
- '(substitute* "src/error.h"
- (("__DATE__") "\"1970-01-01\"")
- (("__TIME__") "\"00:00:00\"")))))
+ (snippet '(begin
+ (substitute* "src/error.h"
+ (("__DATE__") "\"1970-01-01\"")
+ (("__TIME__") "\"00:00:00\""))
+ #t))))
(build-system gnu-build-system)
(inputs
;; TODO: Add dependency on geoip-tools.
@@ -4878,9 +4874,10 @@ on the fly.")
(base32
"0mn5s6p68n32xzadz6ds5i6bp44dyxzkq68r1yljlv470jr84bql"))
(modules '((guix build utils)))
- (snippet
- ;; Remove non-free IETF RFC documentation.
- '(delete-file-recursively "doc"))))
+ (snippet '(begin
+ ;; Remove non-free IETF RFC documentation.
+ (delete-file-recursively "doc")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -5014,9 +5011,10 @@ functions of Tidy.")
(uri (string-append "https://www.hiawatha-webserver.org/files/"
"hiawatha-" version ".tar.gz"))
(modules '((guix build utils)))
- (snippet
- ;; We use our packaged mbedtls, so delete the included copy.
- '(delete-file-recursively "mbedtls"))
+ (snippet '(begin
+ ;; We use our packaged mbedtls, so delete the included copy.
+ (delete-file-recursively "mbedtls")
+ #t))
(sha256
(base32
"0x2zfc8kc6c7rl4gwymwmg13w1c60biv6c6c9fvzpnl59bc9jgin"))))