aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm41
1 files changed, 39 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ccba7ce7e6..64d6874001 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -73,6 +73,7 @@
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages java)
#:use-module (gnu packages javascript)
#:use-module (gnu packages image)
#:use-module (gnu packages libidn)
@@ -306,6 +307,42 @@ such as high performance, preforking, signal support, superdaemon awareness,
and UNIX socket support.")
(license l:perl-license)))
+(define-public icedtea-web
+ (package
+ (name "icedtea-web")
+ (version "1.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://icedtea.wildebeest.org/download/source/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "004kwrngyxxlrlzby4vzxjr0xcyngcdc9dfgnvi61ffnjr006ryf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-plugin" ;NPAPI plugins are obsolete nowadays.
+ (string-append "BIN_BASH=" (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--with-jdk-home=" (assoc-ref %build-inputs "jdk")))))
+ (outputs '("out" "doc"))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("zip" ,zip)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("jdk" ,icedtea "jdk")))
+ (home-page "http://icedtea.classpath.org/wiki/IcedTea-Web")
+ (synopsis "Java Web Start")
+ (description
+ "IcedTea-Web is an implementation of the @dfn{Java Network Launching
+Protocol}, also known as Java Web Start. This package provides tools and
+libraries for working with JNLP applets.")
+ ;; The program is mainly GPL2+, with some individual files under LGPL2.1+
+ ;; or dual licenses.
+ (license l:gpl2+)))
+
(define-public jansson
(package
(name "jansson")
@@ -4763,7 +4800,7 @@ command-line arguments or read from stdin.")
(define-public python-internetarchive
(package
(name "python-internetarchive")
- (version "1.6.0")
+ (version "1.7.1")
(source
(origin
(method url-fetch)
@@ -4772,7 +4809,7 @@ command-line arguments or read from stdin.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "00v1489rv1ydcihwbdl7sqpcpmm98b9kqqlfggr32k0ndmv7ivas"))))
+ "1lj4r0y67mwjns2gcjvw0y7m5x0vqir2iv7s4q2y93492azli1qh"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; 11 tests of 105 fail to mock "requests".