summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index bea9f3dcc7..591ae2cb74 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -767,6 +767,7 @@ current version of any major web browser.")
(sha256
(base32
"1jixgb8w97l9gdh3inihz7avz7i770gy2j2irvvlyrq3wi41f5ab"))
+ (patches (search-patches "rapidjson-gcc-compat.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -906,11 +907,13 @@ high performance.")
"04pfagb7ppq3yibx4lhazd1v9nwkxdfkyy2rgcrmrf3mldsirga1"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+
+ ;; For tests.
+ ("python" ,python-wrapper)))
(inputs
`(("libidn2" ,libidn2)
- ("libunistring" ,libunistring)
- ("python-2" ,python-2)))
+ ("libunistring" ,libunistring)))
(home-page "https://github.com/rockdaboot/libpsl")
(synopsis "C library for the Publix Suffix List")
(description
@@ -6380,7 +6383,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(define-public nghttp2
(package
(name "nghttp2")
- (version "1.35.1")
+ (version "1.39.1")
(source
(origin
(method url-fetch)
@@ -6389,13 +6392,12 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0fi6qg2w82636wixwkqy7bclpgxslmvg82r431hs8h6aqc4mnzwv"))))
+ "0j0lk37k8k3f61r9nw647hg4b22z1753l36n3xrp9x01civ614b7"))))
(build-system gnu-build-system)
(outputs (list "out"
"lib")) ; only libnghttp2
(native-inputs
`(("pkg-config" ,pkg-config)
- ("gcc" ,gcc-7) ; 1.35.0 requires GCC6 or later
;; Required by tests.
("cunit" ,cunit)
@@ -6427,9 +6429,6 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(("@prefix@")
(assoc-ref outputs "lib")))
#t))
- (add-before 'configure 'work-around-bug-30756
- (lambda _
- (for-each unsetenv '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH")) #t))
(add-before 'check 'set-timezone-directory
(lambda* (#:key inputs #:allow-other-keys)
(setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")