summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d91f2995ba..d20047ae15 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3254,6 +3255,35 @@ IO::Socket::INET, so you can perform socket operations directly on it too.")
used by the HTTP protocol (and then some more).")
(home-page "https://metacpan.org/release/HTTP-Date")))
+(define-public perl-http-lite
+ (package
+ (name "perl-http-lite")
+ (version "2.44")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/N/NE/NEILB/HTTP-Lite-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0z77nflj8zdcfg70kc93glq5kmd6qxn2nf7h70x4xhfg25wkvr1q"))))
+ (build-system perl-build-system)
+ (native-inputs `(("perl-cgi" ,perl-cgi)))
+ (home-page "https://metacpan.org/release/HTTP-Lite")
+ (synopsis "Lightweight HTTP implementation")
+ (description "@code{HTTP::Lite} is a stand-alone lightweight
+HTTP/1.1 implementation for perl. It is intended for use in
+situations where it is desirable to install the minimal number of
+modules to achieve HTTP support. @code{HTTP::Lite} is ideal for
+CGI (or mod_perl) programs or for bundling for redistribution with
+larger packages where only HTTP GET and POST functionality are
+necessary. @code{HTTP::Lite} is compliant with the Host header,
+necessary for name based virtual hosting, and supports proxies.
+Additionally, @code{HTTP::Lite} supports a callback to allow
+processing of request data as it arrives.")
+ (license license:perl-license)))
+
(define-public perl-http-message
(package
(name "perl-http-message")