summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5296c43c53..f0f974661b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;;
@@ -258,18 +258,11 @@ for efficient socket-like bidirectional reliable communication channels.")
("which" ,which)
("libtool" ,libtool)))
(arguments
- `(#:phases (alist-cons-before
- 'bootstrap 'fix-autogen-shebang
+ `(#:phases (alist-cons-after
+ 'unpack 'bootstrap
(lambda _
- (substitute* "autogen.sh"
- ;; Removing -e as it causes the whole script to fail when
- ;; `which gtkdocize` fails.
- (("# !/bin/sh -e") (string-append "#!" (which "sh")))))
- (alist-cons-before
- 'patch-usr-bin-file 'bootstrap
- (lambda _
- (zero? (system* "./autogen.sh")))
- %standard-phases))))
+ (zero? (system* "sh" "autogen.sh")))
+ %standard-phases)))
(home-page "https://github.com/rockdaboot/libpsl")
(synopsis "C library for the Publix Suffix List")
(description