summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm34
1 files changed, 21 insertions, 13 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 96e188a600..28f32df609 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -219,14 +219,14 @@ Interface} specification.")
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
;; Consider updating the nginx-documentation package together with this one.
- (version "1.17.7")
+ (version "1.17.8")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "1zwiqljhzf0ym6r3hrg6k2qfb2mxi7i0lpafg4xnkr875225c9xn"))))
+ "0nwn4md8sxhks2j77qq1nvk5pfz3yykfhh2b507b6l2idp7kxllp"))))
(build-system gnu-build-system)
(inputs `(("openssl" ,openssl)
("pcre" ,pcre)
@@ -1095,16 +1095,21 @@ for efficient socket-like bidirectional reliable communication channels.")
(description "WABT (pronounced: wabbit) is a suite of tools for
WebAssembly, including:
-* wat2wasm: translate from WebAssembly text format to the WebAssembly binary
- format
-* wasm2wat: the inverse of wat2wasm, translate from the binary format back
- to the text format (also known as a .wat)
-* wasm-objdump: print information about a wasm binary. Similar to objdump.
-* wasm-interp: decode and run a WebAssembly binary file using a stack-based
- interpreter
-* wat-desugar: parse .wat text form as supported by the spec interpreter
- (s-expressions, flat syntax, or mixed) and print canonical flat format
-* wasm2c: convert a WebAssembly binary file to a C source and header
+@enumerate
+@item @command{wat2wasm} translates from WebAssembly text format to the
+WebAssembly binary format
+@item @command{wasm2wat} is the inverse; it translates from the binary format
+back to the text format (also known as a .wat)
+@item @command{wasm-objdump} prints information about a wasm binary, similarly
+to @command{objdump}.
+@item @command{wasm-interp} decodes ands run a WebAssembly binary file using a
+stack-based interpreter
+@item @command{wat-desugar} parses .wat text form as supported by the spec
+interpreter (s-expressions, flat syntax, or mixed) and prints the canonical
+flat format
+@item @command{wasm2c} converts a WebAssembly binary file to a C source and
+header file.
+@end enumerate
These tools are intended for use in (or for development of) toolchains or
other systems that want to manipulate WebAssembly files.")
@@ -1158,10 +1163,13 @@ high performance.")
(sha256
(base32 "0ak9a6hsanhys40yhv7c2gqkfghpm6jx36j1pnml8ajvgaky5q98"))))
(build-system gnu-build-system)
+ (arguments
+ ;; Parallel builds don't reliably succeed.
+ `(#:parallel-build? #f))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("cunit" ,cunit) ; For tests.
+ ("cunit" ,cunit) ; for tests
("libtool" ,libtool)
("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)))