summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm52
1 files changed, 48 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2b1585c8e3..e6883b7365 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -153,14 +154,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.41")
+ (version "2.4.43")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "0h7a31yxwyh7h521frnmlppl0h7sh9icc3ka6vlmlcg5iwllhg8k"))))
+ "0hqgw47r3p3521ygkkqs8s30s5crm683081avj6330gwncm6b5x4"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)
@@ -3258,6 +3259,35 @@ IO::Socket::INET, so you can perform socket operations directly on it too.")
used by the HTTP protocol (and then some more).")
(home-page "https://metacpan.org/release/HTTP-Date")))
+(define-public perl-http-lite
+ (package
+ (name "perl-http-lite")
+ (version "2.44")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/N/NE/NEILB/HTTP-Lite-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0z77nflj8zdcfg70kc93glq5kmd6qxn2nf7h70x4xhfg25wkvr1q"))))
+ (build-system perl-build-system)
+ (native-inputs `(("perl-cgi" ,perl-cgi)))
+ (home-page "https://metacpan.org/release/HTTP-Lite")
+ (synopsis "Lightweight HTTP implementation")
+ (description "@code{HTTP::Lite} is a stand-alone lightweight
+HTTP/1.1 implementation for perl. It is intended for use in
+situations where it is desirable to install the minimal number of
+modules to achieve HTTP support. @code{HTTP::Lite} is ideal for
+CGI (or mod_perl) programs or for bundling for redistribution with
+larger packages where only HTTP GET and POST functionality are
+necessary. @code{HTTP::Lite} is compliant with the Host header,
+necessary for name based virtual hosting, and supports proxies.
+Additionally, @code{HTTP::Lite} supports a callback to allow
+processing of request data as it arrives.")
+ (license license:perl-license)))
+
(define-public perl-http-message
(package
(name "perl-http-message")
@@ -5792,6 +5822,20 @@ into your tests. It automatically starts up a HTTP server in a separate thread
(uri (git-reference (url home-page)
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (patches
+ ;; When parsing URLs, treat an empty port (eg
+ ;; `http://hostname:/`) as if it were unspecified. This patch is
+ ;; applied to Fedora's http-parser and to libgit2's bundled version.
+ (list
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://src.fedoraproject.org/rpms/http-parser/raw/"
+ "e89b4c4e2874c19079a5a1a2d2ccc61b551aa289/"
+ "f/0001-url-treat-empty-port-as-default.patch"))
+ (sha256
+ (base32
+ "0pbxf2nq9pcn299k2b2ls8ldghaqln9glnp79gi57mamx4iy0f6g")))))
(sha256
(base32
"189zi61vczqgmqjd2myjcjbbi5icrk7ccs0kn6nj8hxqiv5j3811"))))
@@ -6101,12 +6145,12 @@ file links.")
`(#:configure-flags (list "--with-ssl=openssl")
#:tests? #f)) ;No tests included
(native-inputs
- `(("gettext" ,gnu-gettext)
+ `(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)
("intltool" ,intltool)))
(inputs
`(("expat" ,expat)
- ("openssl" ,openssl)))
+ ("openssl" ,openssl-1.0)))
(home-page "http://www.webdav.org/cadaver/")
(synopsis "Command-line WebDAV client")
(description