summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm78
1 files changed, 38 insertions, 40 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 578cfca560..6caa486b84 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -364,45 +364,44 @@ driven and does not detract you from your daily work.")
(license license:gpl3+)))
(define-public next-gtk-webkit
- (let ((commit "b8899341bbdefd0a33412608fbb0b1f92f818c65"))
- (package
- (name "next-gtk-webkit")
- (version (git-version "1.0.0" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://source.atlas.engineer/public/next")
- (commit commit)))
- (sha256
- (base32
- "12jmf1b9qr85il9h15mb9vpsfh1wzcln9x9xpn4lps0kkccnpkz9"))
- (file-name (git-file-name "next" version))))
- (build-system glib-or-gtk-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:make-flags (list "gtk-webkit"
- "CC=gcc"
- (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- (apply invoke "make" "install-gtk-webkit" make-flags))))))
- (inputs
- `(("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("webkitgtk" ,webkitgtk)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "https://next.atlas.engineer")
- (synopsis "Infinitely extensible web-browser (user interface only)")
- (description "Next is a keyboard-oriented, extensible web-browser
+ (package
+ (name "next-gtk-webkit")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.atlas.engineer/public/next")
+ (commit version)))
+ (sha256
+ (base32
+ "00xi01r6gxlrv7xc2dhf4da30y0vng1snbdmc8d829qyn0chl55q"))
+ (file-name (git-file-name "next" version))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags (list "gtk-webkit"
+ "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" "install-gtk-webkit" make-flags))))))
+ (inputs
+ `(("glib-networking" ,glib-networking)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("webkitgtk" ,webkitgtk)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://next.atlas.engineer")
+ (synopsis "Infinitely extensible web-browser (user interface only)")
+ (description "Next is a keyboard-oriented, extensible web-browser
inspired by Emacs and designed for power users. The application has familiar
key-bindings, is fully configurable and extensible in Lisp, and has powerful
features for productive professionals.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public sbcl-next
(package
@@ -428,8 +427,6 @@ features for productive professionals.")
(define expected-fasl (string-append
lib
"/lib/sbcl/next--system.fasl"))
- (pk actual-fasl)
- (pk expected-fasl)
(copy-file actual-fasl expected-fasl)
#t))
(add-after 'create-symlinks 'build-program
@@ -445,6 +442,9 @@ features for productive professionals.")
;; the illegal version will result in NIL in the .desktop
;; file.
(lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "version"
+ (lambda _
+ (format #t "~a" ,(package-version next-gtk-webkit))))
(invoke "make" "install-assets"
(string-append "PREFIX="
(assoc-ref outputs "out"))))))))
@@ -456,14 +456,12 @@ features for productive professionals.")
("cl-strings" ,sbcl-cl-strings)
("cl-string-match" ,sbcl-cl-string-match)
("puri" ,sbcl-puri)
- ("queues.simple-queue" ,sbcl-queues.simple-queue)
("sqlite" ,sbcl-cl-sqlite)
("parenscript" ,sbcl-parenscript)
("cl-json" ,sbcl-cl-json)
("swank" ,sbcl-slime-swank)
("cl-markup" ,sbcl-cl-markup)
("cl-css" ,sbcl-cl-css)
- ("usocket" ,sbcl-usocket)
("bordeaux-threads" ,sbcl-bordeaux-threads)
("s-xml-rpc" ,sbcl-s-xml-rpc)
("unix-opts" ,sbcl-unix-opts)))