summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm181
1 files changed, 117 insertions, 64 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index cb281920e9..8fafe438d0 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -365,10 +365,10 @@ vim editor and also easily configurable during runtime. Vimb is mostly keyboard
driven and does not detract you from your daily work.")
(license license:gpl3+)))
-(define-public next-gtk-webkit
+(define next-gtk-webkit
(package
(name "next-gtk-webkit")
- (version "1.2.2")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -377,7 +377,7 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "1bif1k738knhifxhkn0d2x1m521zkx40pri44vyjqncp9r95hkbk"))
+ "0ibq30xrf871pkpasi8p9krn0pmd86rsdzb3jqvz3wnp4wa3hl9d"))
(file-name (git-file-name "next" version))))
(build-system glib-or-gtk-build-system)
(arguments
@@ -405,71 +405,124 @@ key-bindings, is fully configurable and extensible in Lisp, and has powerful
features for productive professionals.")
(license license:bsd-3)))
-(define-public sbcl-next
+(define sbcl-next-download-manager
(package
(inherit next-gtk-webkit)
- (name "sbcl-next")
+ (name "sbcl-next-download-manager")
(build-system asdf-build-system/sbcl)
- (outputs '("out" "lib"))
(arguments
- `(#:tests? #f ; no tests
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-platform-port-path
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "source/ports/gtk-webkit.lisp"
- (("\"next-gtk-webkit\"")
- (string-append "\"" (assoc-ref inputs "next-gtk-webkit")
- "/bin/next-gtk-webkit\"")))))
- (add-before 'cleanup 'move-bundle
- (lambda* (#:key outputs #:allow-other-keys)
- (define lib (assoc-ref outputs "lib"))
- (define actual-fasl (string-append
- lib
- "/lib/sbcl/next.fasl"))
- (define expected-fasl (string-append
- lib
- "/lib/sbcl/next--system.fasl"))
- (copy-file actual-fasl expected-fasl)
- #t))
- (add-after 'create-symlinks 'build-program
- (lambda* (#:key outputs #:allow-other-keys)
- (build-program
- (string-append (assoc-ref outputs "out") "/bin/next")
- outputs
- #:entry-program '((next:start-with-port) 0))))
- (add-before 'build 'install-assets
- ;; Since the ASDF build system generates a new .asd with a
- ;; possibly suffixed and thus illegal version number, assets
- ;; should not be installed after the 'build phase or else
- ;; the illegal version will result in NIL in the .desktop
- ;; file.
- (lambda* (#:key outputs #:allow-other-keys)
- (with-output-to-file "version"
- (lambda _
- (format #t "~a" ,(package-version next-gtk-webkit))))
- (invoke "make" "install-assets"
- (string-append "PREFIX="
- (assoc-ref outputs "out"))))))))
+ `(#:tests? #f ; Need online access.
+ #:asd-file "next.asd"
+ #:asd-system-name "download-manager"))
(inputs
- `(("next-gtk-webkit" ,next-gtk-webkit)
- ;; Lisp libraries:
+ `(;; ASD libraries:
("trivial-features" ,sbcl-trivial-features)
- ("alexandria" ,sbcl-alexandria)
- ("anaphora" ,sbcl-anaphora)
- ("closer-mop" ,sbcl-closer-mop)
+ ;; Lisp libraries:
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("dexador" ,sbcl-dexador)
("log4cl" ,sbcl-log4cl)
- ("find-port" ,sbcl-find-port)
- ("cl-strings" ,sbcl-cl-strings)
- ("cl-string-match" ,sbcl-cl-string-match)
- ("puri" ,sbcl-puri)
- ("sqlite" ,sbcl-cl-sqlite)
- ("parenscript" ,sbcl-parenscript)
- ("cl-json" ,sbcl-cl-json)
- ("swank" ,sbcl-slime-swank)
- ("cl-markup" ,sbcl-cl-markup)
- ("cl-css" ,sbcl-cl-css)
- ("bordeaux-threads" ,sbcl-bordeaux-threads)
- ("s-xml-rpc" ,sbcl-s-xml-rpc)
- ("unix-opts" ,sbcl-unix-opts)
- ("trivial-clipboard" ,sbcl-trivial-clipboard)))
- (synopsis "Infinitely extensible web-browser (with Lisp development files)")))
+ ("lparallel" ,sbcl-lparallel)
+ ("quri" ,sbcl-quri)
+ ("str" ,sbcl-cl-str)))
+ (native-inputs
+ `(("prove-asdf" ,sbcl-prove-asdf)))
+ (synopsis "Infinitely extensible web-browser (download manager)")))
+
+(define-public next
+ (let ((version (package-version next-gtk-webkit)))
+ (package
+ (inherit next-gtk-webkit)
+ (name "next")
+ (build-system asdf-build-system/sbcl)
+ (outputs '("out" "lib"))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:asd-system-name "next"
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-platform-port-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "source/ports/gtk-webkit.lisp"
+ (("\"next-gtk-webkit\"")
+ (string-append "\"" (assoc-ref inputs "next-gtk-webkit")
+ "/bin/next-gtk-webkit\"")))
+ #t))
+ (add-after 'patch-platform-port-path 'patch-version
+ ;; When the version is not just dot-separated numerals
+ ;; (e.g. a git-commit version), Guix modifies the .asd with
+ ;; an illegal version number, and then Next fails to query
+ ;; it. So we hard-code it here.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((version (format #f "~a" ,version)))
+ (substitute* "source/global.lisp"
+ (("version\\)\\)\\)")
+ (string-append "version)))
+(setf +version+ \"" version "\")"))))
+ #t))
+ (add-before 'cleanup 'move-bundle
+ (lambda* (#:key outputs #:allow-other-keys)
+ (define lib (assoc-ref outputs "lib"))
+ (define actual-fasl (string-append
+ lib
+ "/lib/sbcl/next.fasl"))
+ (define expected-fasl (string-append
+ lib
+ "/lib/sbcl/next--system.fasl"))
+ (copy-file actual-fasl expected-fasl)
+ #t))
+ (add-after 'create-symlinks 'build-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (build-program
+ (string-append (assoc-ref outputs "out") "/bin/next")
+ outputs
+ #:entry-program '((next:entry-point) 0))))
+ (add-before 'build 'install-assets
+ ;; Since the ASDF build system generates a new .asd with a
+ ;; possibly suffixed and thus illegal version number, assets
+ ;; should not be installed after the 'build phase or else
+ ;; the illegal version will result in NIL in the .desktop
+ ;; file.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "version"
+ (lambda _
+ (format #t "~a" ,(package-version next-gtk-webkit))))
+ (invoke "make" "install-assets"
+ (string-append "PREFIX="
+ (assoc-ref outputs "out"))))))))
+ (inputs
+ `(("next-gtk-webkit" ,next-gtk-webkit)
+ ;; ASD libraries:
+ ("trivial-features" ,sbcl-trivial-features)
+ ("trivial-garbage" ,sbcl-trivial-garbage)
+ ;; Lisp libraries:
+ ("alexandria" ,sbcl-alexandria)
+ ("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("cl-css" ,sbcl-cl-css)
+ ("cl-json" ,sbcl-cl-json)
+ ("cl-markup" ,sbcl-cl-markup)
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)
+ ("cl-string-match" ,sbcl-cl-string-match)
+ ("cl-strings" ,sbcl-cl-strings)
+ ("closer-mop" ,sbcl-closer-mop)
+ ("dbus" ,cl-dbus)
+ ("dexador" ,sbcl-dexador)
+ ("ironclad" ,sbcl-ironclad)
+ ("log4cl" ,sbcl-log4cl)
+ ("lparallel" ,sbcl-lparallel)
+ ("mk-string-metrics" ,sbcl-mk-string-metrics)
+ ("parenscript" ,sbcl-parenscript)
+ ("quri" ,sbcl-quri)
+ ("sqlite" ,sbcl-cl-sqlite)
+ ("str" ,sbcl-cl-str)
+ ("swank" ,sbcl-slime-swank)
+ ("trivia" ,sbcl-trivia)
+ ("trivial-clipboard" ,sbcl-trivial-clipboard)
+ ("unix-opts" ,sbcl-unix-opts)
+ ;; Local deps
+ ("next-download-manager" ,sbcl-next-download-manager)))
+ (native-inputs
+ `(("prove-asdf" ,sbcl-prove-asdf)))
+ (synopsis "Infinitely extensible web-browser (with Lisp development files)"))))
+
+(define-public sbcl-next
+ (deprecated-package "sbcl-next" next))