summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm30
1 files changed, 4 insertions, 26 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index a924bcc107..61a01f56b8 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -149,7 +149,7 @@ interpretation of the specifications for these languages.")
(define-public vulkan-headers
(package
(name "vulkan-headers")
- (version "1.1.114")
+ (version "1.1.121")
(source
(origin
(method git-fetch)
@@ -159,7 +159,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fdvh26nxibylh32lj8b62d9nf9j25xa0il9zg362wmr2zgm8gka"))))
+ "0hbgbdxj7lrm37phb0pkq5zgss3h21znj3mivnyva5f60i2wgr73"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; No tests.
@@ -183,7 +183,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1rkm6dzdzxva62shscipz3kpp66x4kgmwvp1ski2fvf4jzzcbv7h"))))
+ "1gbrppfxrncvva30fikgzm7f15xs527sb4lf1sswdyxj3h5cw741"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;FIXME: 23/39 tests fail. Try "tests/run_all_tests.sh".
@@ -193,28 +193,6 @@ interpretation of the specifications for these languages.")
(lambda* (#:key inputs #:allow-other-keys)
;; Remove lines trying to build in a git commit id.
(substitute* "CMakeLists.txt" ((".*spirv_tools_commit_id.h.*") ""))
- #t))
- ;; Make sure that the files needed for Mesa's Vulkan overlay are availabe.
- (add-after 'unpack 'copy-headers1
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "tests/layers/vk_layer_data.h"
- (string-append (assoc-ref %outputs "out")
- "/include/vulkan"))
- (install-file "tests/layers/vk_layer_extension_utils.h"
- (string-append (assoc-ref %outputs "out")
- "/include/vulkan"))
- (install-file "loader/vk_loader_platform.h"
- (string-append (assoc-ref %outputs "out")
- "/include/vulkan"))
- #t))
- (add-after 'build 'copy-headers2
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "vk_layer_dispatch_table.h"
- (string-append (assoc-ref %outputs "out")
- "/include/vulkan"))
- (install-file "vk_dispatch_table_helper.h"
- (string-append (assoc-ref %outputs "out")
- "/include/vulkan"))
#t)))
#:configure-flags (list
"-DBUILD_TESTS=OFF" ; FIXME: Needs 'googletest' submodule.
@@ -256,7 +234,7 @@ and the ICD.")
(file-name (git-file-name name version))
(sha256
(base32
- "1lz06mpni8ghf1xcxi4g6ck306lfaqwfi6f1w64kp9hczmvapfhf"))))
+ "1jndlz3n35zlz44p1b4cgl2alvsmgrqnkxdn5mpahg0zb8dgwmm8"))))
(build-system cmake-build-system)
(inputs
`(("glslang" ,glslang)