summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm111
1 files changed, 58 insertions, 53 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 997cf57003..0477793076 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -155,22 +155,22 @@
(let ((out (assoc-ref outputs "out"))
(ncurses (assoc-ref inputs "ncurses")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--build=" build)
- ;; The ancient config.guess is unable to
- ;; guess the host triplet on mips64el.
- ,@(if (string=? "mips64el-linux"
- (%current-system))
- '("--host=mips64el-unknown-linux-gnu")
- '())
- ;; The same is also true with aarch64.
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '())
- (string-append "--with-ncurses="
- ncurses)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--build=" build)
+ ;; The ancient config.guess is unable to
+ ;; guess the host triplet on mips64el.
+ ,@(if (string=? "mips64el-linux"
+ (%current-system))
+ '("--host=mips64el-unknown-linux-gnu")
+ '())
+ ;; The same is also true with aarch64.
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())
+ (string-append "--with-ncurses="
+ ncurses))))))))
(home-page "http://aa-project.sourceforge.net/aalib/")
(synopsis "ASCII-art library")
(description
@@ -208,9 +208,8 @@ old-fashioned output methods with powerful ascii-art renderer.")
(modify-phases %standard-phases
;; XXX We need to run ./bootstrap because of the build
;; system fixes above.
- (add-after
- 'unpack 'bootstrap
- (lambda _ (zero? (system* "sh" "bootstrap")))))))
+ (replace 'bootstrap
+ (lambda _ (invoke "sh" "bootstrap"))))))
(home-page "http://liba52.sourceforge.net/")
(synopsis "ATSC A/52 stream decoder")
(description "liba52 is a library for decoding ATSC A/52 streams. The
@@ -306,15 +305,15 @@ H.264 (MPEG-4 AVC) video streams.")
(base32
"0hknnnnx9661igm1r73dc7aqxnnrl5a8yvyvr1nhd9ymn2klwpl5"))
(modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete bundled libraries.
- (for-each delete-file-recursively
- '("lib/libebml"
- "lib/libmatroska"
- "lib/nlohmann-json"
- "lib/pugixml"
- "lib/utf8-cpp"))))))
+ (snippet '(begin
+ ;; Delete bundled libraries.
+ (for-each delete-file-recursively
+ '("lib/libebml"
+ "lib/libmatroska"
+ "lib/nlohmann-json"
+ "lib/pugixml"
+ "lib/utf8-cpp"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("boost" ,boost)
@@ -390,8 +389,9 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
(base32
"1gyd94jkwdii9308m07nymsbxrmrcl81c0j8i10zhslr2mj07w0v"))
(modules '((guix build utils)))
- (snippet
- '(delete-file-recursively "source/compat/getopt"))))
+ (snippet '(begin
+ (delete-file-recursively "source/compat/getopt")
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; tests are skipped if cpu-optimized code isn't built
@@ -577,7 +577,8 @@ libebml is a C++ library to read and write EBML files.")
(let ((out (assoc-ref outputs "out")))
(substitute* "va/drm/va_drm_auth_x11.c"
(("\"libva-x11\\.so\\.%d\"")
- (string-append "\"" out "/lib/libva-x11.so.%d\"")))))))
+ (string-append "\"" out "/lib/libva-x11.so.%d\"")))
+ #t))))
;; Most drivers are in mesa's $prefix/lib/dri, so use that. (Can be
;; overridden at run-time via LIBVA_DRIVERS_PATH.)
#:configure-flags
@@ -749,13 +750,13 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
(("#! /bin/sh") (string-append "#!" (which "sh"))))
(setenv "SHELL" (which "bash"))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero? (apply system*
- "./configure"
- (string-append "--prefix=" out)
- ;; Add $libdir to the RUNPATH of all the binaries.
- (string-append "--extra-ldflags=-Wl,-rpath="
- out "/lib")
- configure-flags)))))
+ (apply invoke
+ "./configure"
+ (string-append "--prefix=" out)
+ ;; Add $libdir to the RUNPATH of all the binaries.
+ (string-append "--extra-ldflags=-Wl,-rpath="
+ out "/lib")
+ configure-flags))))
(add-before
'check 'set-ld-library-path
(lambda _
@@ -1070,7 +1071,8 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
'configure 'setup-waf
(lambda* (#:key inputs #:allow-other-keys)
(copy-file (assoc-ref inputs "waf") "waf")
- (setenv "CC" "gcc"))))
+ (setenv "CC" "gcc")
+ #t)))
#:configure-flags (list "--enable-libmpv-shared"
"--enable-cdda"
"--enable-dvdread"
@@ -1826,10 +1828,11 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(base32
"10m3ry0b2pvqx3bk34qh5dq337nn8pkc2gzfyhsj4nv9abskln47"))
(modules '((guix build utils)))
- (snippet
- ;; As of glibc 2.26, <xlocale.h> no longer is.
- '(substitute* "src/framework/mlt_property.h"
- (("xlocale\\.h") "locale.h")))))
+ (snippet '(begin
+ ;; As of glibc 2.26, <xlocale.h> no longer is.
+ (substitute* "src/framework/mlt_property.h"
+ (("xlocale\\.h") "locale.h"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1966,9 +1969,9 @@ and JACK.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("dri2proto" ,dri2proto)
- ("libx11" ,libx11 "out")
- ("libxext" ,libxext)))
+ `(("libx11" ,libx11 "out")
+ ("libxext" ,libxext)
+ ("xorgproto" ,xorgproto)))
(home-page "https://wiki.freedesktop.org/www/Software/VDPAU/")
(synopsis "Video Decode and Presentation API")
(description "VDPAU is the Video Decode and Presentation API for UNIX. It
@@ -2015,7 +2018,8 @@ implementation.")
"1x2ag1f2fwa4yh1g5spv99w9x1m33hbxlqwyhm205ssq0ra234bx"))
(patches (search-patches "libvdpau-va-gl-unbundle.patch"))
(modules '((guix build utils)))
- (snippet '(delete-file-recursively "3rdparty"))))
+ (snippet '(begin (delete-file-recursively "3rdparty")
+ #t))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; Tests require a running X11 server, with VA-API support.
@@ -2282,7 +2286,7 @@ supported players in addition to this package.")
`(#:tests? #f ;tests require Ruby and claim to be unsupported
#:phases
(modify-phases %standard-phases
- (add-before 'patch-source-shebangs 'bootstrap-gtk
+ (replace 'bootstrap
;; Run bootstrap ahead of time so that shebangs get patched.
(lambda _
(setenv "CONFIG_SHELL" (which "sh"))
@@ -2527,10 +2531,11 @@ many codecs and formats supported by libmediainfo.")
(base32
"0f5kxpayqn3yhabqrd2cqlc74i6x2xr01jfkank1lcilxnfyrsnq"))
(modules '((guix build utils)))
- (snippet
- ;; As of glibc 2.26, <xlocale.h> no longer is.
- '(substitute* "liveMedia/include/Locale.hh"
- (("xlocale\\.h") "locale.h")))))
+ (snippet '(begin
+ ;; As of glibc 2.26, <xlocale.h> no longer is.
+ (substitute* "liveMedia/include/Locale.hh"
+ (("xlocale\\.h") "locale.h"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
@@ -2801,7 +2806,7 @@ It counts more than 100 plugins.")
("sqlite" ,sqlite)))
(arguments
'(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
+ (replace 'bootstrap
(lambda _
(patch-shebang "version.sh")
(invoke "autoreconf" "-vfi"))))