summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm103
1 files changed, 49 insertions, 54 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cf767f43bf..74a9b948ad 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -272,41 +272,37 @@ television and DVD. It is also known as AC-3.")
(license license:gpl2+)))
(define-public libaom
- ;; The 1.0.0-errata1 release installs a broken pkg-config .pc file. This
- ;; is fixed in libaom commit 0ddc150, but we use an even later commit.
- (let ((commit "22b150bf040608028a56d8bf39e72f771383d836")
- (revision "0"))
- (package
- (name "libaom")
- (version (git-version "1.0.0-errata1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://aomedia.googlesource.com/aom/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1pdd5h3n42607n6qmggz4yv8izhjr2kl6knb3kh7gh4v0vy47h1r"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python))) ; to detect the version
- (arguments
- `(#:tests? #f ;no check target
- #:configure-flags
- ;; build dynamic library
- (list "-DBUILD_SHARED_LIBS=YES"
- "-DENABLE_PIC=TRUE"
- "-DAOM_TARGET_CPU=generic"
- (string-append "-DCMAKE_INSTALL_PREFIX="
- (assoc-ref %outputs "out")))))
- (home-page "https://aomedia.googlesource.com/aom/")
- (synopsis "AV1 video codec")
- (description "Libaom is the reference implementation of AV1. It includes
-a shared library and encoder and decoder command-line executables.")
- (license license:bsd-2))))
+ (package
+ (name "libaom")
+ (version "1.0.0-errata1-avif")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://aomedia.googlesource.com/aom/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "169yfgh7zigc21h71qclfyr7s4wwp2i9vbr4z6pkabypvass4v7m"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python))) ; to detect the version
+ (arguments
+ `(#:tests? #f ;no check target
+ #:configure-flags
+ ;; build dynamic library
+ (list "-DBUILD_SHARED_LIBS=YES"
+ "-DENABLE_PIC=TRUE"
+ "-DAOM_TARGET_CPU=generic"
+ (string-append "-DCMAKE_INSTALL_PREFIX="
+ (assoc-ref %outputs "out")))))
+ (home-page "https://aomedia.googlesource.com/aom/")
+ (synopsis "AV1 video codec")
+ (description "Libaom is the reference implementation of AV1. It includes a
+shared library and encoder and decoder command-line executables.")
+ (license license:bsd-2)))
(define-public libmpeg2
(package
@@ -1264,7 +1260,7 @@ streaming protocols.")
(define-public mplayer
(package
(name "mplayer")
- (version "1.3.0")
+ (version "1.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1272,7 +1268,7 @@ streaming protocols.")
version ".tar.xz"))
(sha256
(base32
- "0hwqn04bdknb2ic88xd75smffxx63scvz0zvwvjb56nqj9n89l1s"))))
+ "0j5mflr0wnklxsvnpmxvk704hscyn2785hvvihj2i3a7b3anwnc2"))))
(build-system gnu-build-system)
;; FIXME: Add additional inputs once available.
(native-inputs
@@ -1281,17 +1277,18 @@ streaming protocols.")
(inputs
`(("alsa-lib" ,alsa-lib)
("cdparanoia" ,cdparanoia)
- ("ffmpeg" ,ffmpeg-3.4)
+ ("ffmpeg" ,ffmpeg)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
-;; ("giflib" ,giflib) ; uses QuantizeBuffer, requires version >= 5
+ ("giflib" ,giflib)
("lame" ,lame)
("libass" ,libass)
("libdvdcss" ,libdvdcss)
- ("libdvdnav" ,libdvdnav)
+ ("libdvdnav" ,libdvdnav) ; ignored without libdvdread
+ ("libdvdread" ,libdvdread) ; ignored without libdvdnav
("libjpeg" ,libjpeg-turbo)
("libmpeg2" ,libmpeg2)
- ("libmpg123" ,mpg123) ; audio codec for MP3
+ ("libmpg123" ,mpg123) ; audio codec for MP3
("libpng" ,libpng)
("libtheora" ,libtheora)
("libvdpau" ,libvdpau)
@@ -1310,7 +1307,7 @@ streaming protocols.")
("speex" ,speex)
("zlib" ,zlib)))
(arguments
- `(#:tests? #f ; no test target
+ `(#:tests? #f ; no test target
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -1346,7 +1343,7 @@ streaming protocols.")
(nix-system->gnu-triplet
(%current-system)))))))
"--disable-iwmmxt")))))))
- (home-page "https://www.mplayerhq.hu/design7/news.html")
+ (home-page "https://www.mplayerhq.hu")
(synopsis "Audio and video player")
(description "MPlayer is a movie player. It plays most MPEG/VOB, AVI,
Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4, RealMedia, Matroska, NUT,
@@ -1551,7 +1548,7 @@ To load this plugin, specify the following option when starting mpv:
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2020.01.24")
+ (version "2020.02.16")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ytdl-org/youtube-dl/"
@@ -1559,7 +1556,7 @@ To load this plugin, specify the following option when starting mpv:
version ".tar.gz"))
(sha256
(base32
- "1zrnbjnwv315f9a83lk5c0gl4ianvp6q2kinxvqlv604sabcq78b"))))
+ "1ip0p7gifwmkls8ppfvz89j1lh82dg60zmvabj8njnhj170ikkdb"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1690,7 +1687,7 @@ other site that youtube-dl supports.")
(define-public you-get
(package
(name "you-get")
- (version "0.4.1355")
+ (version "0.4.1403")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1699,7 +1696,7 @@ other site that youtube-dl supports.")
(file-name (git-file-name name version))
(sha256
(base32
- "0xq7z04hvw3b3npiahlpzhbxsjvam9n9dynplyrkn84dx6k9ajbj"))))
+ "04viy19x4g9dngml82nf9j94ys3p47bs62c2q2cn1barkybaa3as"))))
(build-system python-build-system)
(inputs
`(("ffmpeg" ,ffmpeg))) ; for multi-part and >=1080p videos
@@ -2149,7 +2146,7 @@ format changes.")
(define-public xvid
(package
(name "xvid")
- (version "1.3.6")
+ (version "1.3.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2157,21 +2154,19 @@ format changes.")
version ".tar.bz2"))
(sha256
(base32
- "0zppakvcgq5a42mhqqsbliclpg2jrhbmbfgrzalyfzr47jqmhssy"))))
+ "1xyg3amgg27zf7188kss7y248s0xhh1vv8rrk0j9bcsd5nasxsmf"))))
(build-system gnu-build-system)
(native-inputs `(("yasm" ,yasm)))
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'pre-configure
+ (add-before 'configure 'pre-configure
(lambda _
(chdir "build/generic")
(substitute* "configure"
(("#! /bin/sh") (string-append "#!" (which "sh"))))
#t)))
- ;; No 'check' target.
- #:tests? #f))
+ #:tests? #f)) ; no test suite
(home-page "https://www.xvid.com/")
(synopsis "MPEG-4 Part 2 Advanced Simple Profile video codec")
(description "Xvid is an MPEG-4 Part 2 Advanced Simple Profile (ASP) video
@@ -2883,7 +2878,7 @@ post-processing of video formats like MPEG2, H.264/AVC, and VC-1.")
#:phases (modify-phases %standard-phases
;; no configure script
(delete 'configure))))
- (home-page "http://www.openh264.org/")
+ (home-page "https://www.openh264.org/")
(synopsis "H264 decoder library")
(description
"Openh264 is a library which can decode H264 video streams.")