summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 86c5870f8f..420d37f020 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2567,14 +2567,14 @@ supported players in addition to this package.")
(define-public handbrake
(package
(name "handbrake")
- (version "1.1.2")
+ (version "1.2.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.handbrake.fr/releases/"
version "/HandBrake-" version "-source.tar.bz2"))
(sha256
(base32
- "0bny0hwlr55g2c69rsamv0xvwmfh1s4a582b9vq20xv5ly84m6ms"))
+ "03clkknaq3mz84p85cvr21gsy9b8vv2g4vvyfz44hz8la253jfqi"))
(modules '((guix build utils)))
(snippet
;; Remove "contrib" and source not necessary for
@@ -2588,11 +2588,13 @@ supported players in addition to this package.")
;; which would lead to fetching and building of these
;; libraries. Use our own instead.
(("MODULES \\+= contrib") "# MODULES += contrib"))
- #t))))
+ #t))
+ (patches (search-patches "handbrake-opt-in-nvenc.patch"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("automake" ,automake) ;gui subpackage must be bootstrapped
("autoconf" ,autoconf)
+ ("cmake" ,cmake) ;TODO: could probably strip check from make/configure.py
("curl" ,curl) ;not actually used, but tested for
("intltool" ,intltool)
("libtool" ,libtool)
@@ -2625,12 +2627,14 @@ supported players in addition to this package.")
("libvpx" ,libvpx)
("libxml2" ,libxml2)
("libx264" ,libx264)
+ ("speex" ,speex)
("x265" ,x265)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ;tests require Ruby and claim to be unsupported
#:configure-flags
- (list (string-append "CPPFLAGS=-I"
+ (list "--disable-gtk-update-checks"
+ (string-append "CPPFLAGS=-I"
(assoc-ref %build-inputs "libxml2")
"/include/libxml2")
"LDFLAGS=-lx265")