summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 055b9a0106..43581e7f62 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -418,6 +418,13 @@ H.264 (MPEG-4 AVC) video streams.")
"--enable-precompiled-headers=no")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-relative-file-names
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "src/mkvtoolnix-gui/util/settings.cpp"
+ (("mkvmerge" match)
+ (string-append out "/bin/" match)))
+ #t)))
(add-before 'configure 'add-googletest
(lambda* (#:key inputs #:allow-other-keys)
(symlink