summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm78
1 files changed, 77 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ac2eec5f94..909d23ad2e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -659,7 +660,10 @@ audio/video codec library.")
"1a22b913p2227ljz89c4fgjlyln5gcz8z58w32r0wh4srnnd60y4"))))
(build-system gnu-build-system)
(native-inputs
- `(("git" ,git) ; needed for a test
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("git" ,git) ; needed for a test
+ ("libtool" ,libtool)
("pkg-config" ,pkg-config)))
;; FIXME: Add optional inputs once available.
(inputs
@@ -673,6 +677,7 @@ audio/video codec library.")
("gnutls" ,gnutls)
("liba52" ,liba52)
("libcddb" ,libcddb)
+ ("libdvbpsi" ,libdvbpsi)
("libgcrypt" ,libgcrypt)
("libkate" ,libkate)
("libmad" ,libmad)
@@ -687,6 +692,7 @@ audio/video codec library.")
("libxinerama" ,libxinerama)
("libxml2" ,libxml2)
("libxpm" ,libxpm)
+ ("livemedia-utils" ,livemedia-utils)
("lua" ,lua-5.1)
("mesa" ,mesa)
("opus" ,opus)
@@ -714,6 +720,15 @@ audio/video codec library.")
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _ (zero? (system* "sh" "bootstrap"))))
+ (add-before 'bootstrap 'fix-livemedia-utils-prefix
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((livemedia-utils (assoc-ref inputs "livemedia-utils")))
+ (substitute* "configure.ac"
+ (("LIVE555_PREFIX=\\$\\{LIVE555_PREFIX-\"/usr\"\\}")
+ (string-append "LIVE555_PREFIX=" livemedia-utils)))
+ #t)))
(add-before 'configure 'remove-visual-tests
;; Some of the tests require using the display to test out VLC,
;; which fails in our sandboxed build system
@@ -2153,3 +2168,64 @@ MPEG-2, MPEG-4, DVD (VOB)...
information and other metadata about audio or video files. It supports the
many codecs and formats supported by libmediainfo.")
(license license:bsd-2)))
+
+(define-public livemedia-utils
+ (package
+ (name "livemedia-utils")
+ (version "2017.05.24")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.live555.com/liveMedia/public/live."
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ra64j3qa89hf3xika8jz9gd8al8mcaqlk5ivw5pclnd2df5f4im"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib")
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'fix-makefiles-generation
+ (lambda _
+ (substitute* "genMakefiles"
+ (("/bin/rm") "rm"))
+ #t))
+ (replace 'configure
+ (lambda _
+ (zero? (system* "./genMakefiles"
+ "linux-with-shared-libraries")))))))
+ (home-page "http://www.live555.com/liveMedia/")
+ (synopsis "Set of C++ libraries for multimedia streaming")
+ (description "This code forms a set of C++ libraries for multimedia
+streaming, using open standard protocols (RTP/RTCP, RTSP, SIP). The libraries
+can be used to stream, receive, and process MPEG, H.265, H.264, H.263+, DV or
+JPEG video, and several audio codecs. They can easily be extended to support
+additional (audio and/or video) codecs, and can also be used to build basic
+RTSP or SIP clients and servers.")
+ (license license:lgpl3+)))
+
+(define-public libdvbpsi
+ (package
+ (name "libdvbpsi")
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.videolan.org/pub/libdvbpsi/"
+ version "/libdvbpsi-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0824r08kaspbrrg2dd5d46s475zb7j59brqkm2y6x3mdsnpng0yn"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.videolan.org/developers/libdvbpsi.html")
+ (synopsis "Library for decoding and generation of MPEG TS and DVB PSI
+tables")
+ (description "libdvbpsi is a simple library designed for decoding and
+generation of MPEG TS and DVB PSI tables according to standards ISO/IEC 13818s
+and ITU-T H.222.0.")
+ (license license:lgpl2.1)))