summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm31
1 files changed, 29 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 30660e830f..cc6e3d3111 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -180,6 +180,33 @@ everything from small to very large projects with speed and efficiency.")
(license gpl2)
(home-page "http://git-scm.com/")))
+(define-public mercurial
+ (package
+ (name "mercurial")
+ (version "2.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://mercurial.selenic.com/release/mercurial-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "121m8f7vmipmdg00cnzdz2rjkgydh28mwfirqkrbs5fv089vywl4"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; Restrict to Python 2, as Python 3 would require
+ ;; the argument --c2to3.
+ #:python ,python-2
+ ;; FIXME: Disabled tests because they require the nose unit
+ ;; testing framework: https://nose.readthedocs.org/en/latest/ .
+ #:tests? #f))
+ (home-page "http://mercurial.selenic.com")
+ (synopsis "Decentralized version control system")
+ (description
+ "Mercurial is a free, distributed source control management tool.
+It efficiently handles projects of any size
+and offers an easy and intuitive interface.")
+ (license gpl2+)))
+
(define-public subversion
(package
(name "subversion")
@@ -226,8 +253,8 @@ everything from small to very large projects with speed and efficiency.")
(home-page "http://subversion.apache.org/")
(synopsis "Subversion, a revision control system")
(description
- "Subversion exists to be universally recognized and adopted as an
-open-source, centralized version control system characterized by its
+ "Subversion exists to be universally recognized and adopted as a
+centralized version control system characterized by its
reliability as a safe haven for valuable data; the simplicity of its model and
usage; and its ability to support the needs of a wide variety of users and
projects, from individuals to large-scale enterprise operations.")