summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3d88ff8a4a..bf34c17deb 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -64,12 +64,11 @@
#:python ,python-2)) ; Python 3 apparently not yet supported, see
; https://answers.launchpad.net/bzr/+question/229048
(home-page "https://gnu.org/software/bazaar")
- (synopsis "Decentralized revision control system")
+ (synopsis "Version control system supporting both distributed and centralized workflows")
(description
- "GNU Bazaar is a distributed version control system, which supports both
-central version control and distributed version control. Developers can
-organize their workspace in whichever way they want. It is possible to work
-from a command line or use a GUI application.")
+ "GNU Bazaar is a version control system that allows you to record
+changes to project files over time. It supports both a distributed workflow
+as well as the classic centralized workflow.")
(license gpl2+)))
(define-public git
@@ -276,9 +275,11 @@ projects, from individuals to large-scale enterprise operations.")
(home-page "http://www.gnu.org/software/rcs/")
(synopsis "Per-file local revision control system")
(description
- "RCS is the Revision Control System. It is used to manage multiple
-revisions of files. Revisions are stored as reverse differences generated by
-GNU Diffutils. RCS also handles identifying and merging revisions.")
+ "RCS is the original Revision Control System. It works on a
+file-by-file basis, in contrast to subsequent version control systems such as
+CVS, Subversion, and Git. This can make it suitable for system
+administration files, for example, which are often inherently local to one
+machine.")
(license gpl3+)))
(define-public cvs
@@ -330,6 +331,6 @@ RCS, PRCS, and Aegis packages.")
vc-dwim is a tool that simplifies the task of maintaining a ChangeLog and
using version control at the same time, for example by printing a reminder
when a file change has been described in the ChangeLog but the file has not
-been added to the VCS. vc-chlog scans changed files and generates
+been added to the VC. vc-chlog scans changed files and generates
standards-compliant ChangeLog entries based on the changes that it detects.")
(license gpl3+)))