summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 88a25f04f1..7fc0244bc9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -253,9 +253,17 @@ as well as the classic centralized workflow.")
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
- ;; We do not have bash-for-tests when cross-compiling.
,@(if (%current-target-system)
- '()
+ ;; The git build system assumes build == host
+ `((add-after 'unpack 'use-host-uname_S
+ (lambda _
+ (substitute* "config.mak.uname"
+ (("uname_S := .*" all)
+ (if (equal? ,(%current-target-system) "i586-pc-gnu")
+ "uname_S := GNU\n"
+ all)))
+ #t)))
+ ;; We do not have bash-for-tests when cross-compiling.
`((add-after 'unpack 'modify-PATH
(lambda* (#:key inputs #:allow-other-keys)
(let ((path (string-split (getenv "PATH") #\:))