summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm36
1 files changed, 27 insertions, 9 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index fdbfab2fa4..5b3955869f 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -148,14 +148,14 @@ as well as the classic centralized workflow.")
(define-public git
(package
(name "git")
- (version "2.26.0")
+ (version "2.26.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1mlmwibfgcv42c28fxmbd3iim8fc06r17dljd8vdgq550z5hvkly"))))
+ "0s03ix9j1h0yychkh1l1cgpr1l9lwzn3rprl08rk8ii5ix02i0l8"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -168,7 +168,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "09ilv5gg7167mwc0qqw2fz3lmdm360crnxc0xzkqn53wnsh4cziq"))))
+ "0j2031x3qchwjmiy2h849j4x1vd8y4rgqv2ak9dc87xbbpsbfg59"))))
;; For subtree documentation.
("asciidoc" ,asciidoc-py3)
("docbook-xsl" ,docbook-xsl)
@@ -653,6 +653,24 @@ write native speed custom Git applications in any language with bindings.")
;; GPLv2 with linking exception
(license license:gpl2)))
+(define-public libgit2-0.28
+ (package
+ (inherit libgit2)
+ (version "0.28.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/libgit2/libgit2/releases/"
+ "download/v" version
+ "/libgit2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hjgpqjjmkciw1i8jqkx9q2vhdc4fc99qajhrj2bq8ziwsp6hyrb"))
+ (patches (search-patches "libgit2-mtime-0.patch"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (delete-file-recursively "deps") #t))))))
+
(define-public git-crypt
(package
(name "git-crypt")
@@ -843,9 +861,9 @@ collaboration using typical untrusted file hosts or services.")
(method url-fetch)
;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
;; which may not match the current (package-version git).
- (uri "mirror://kernel.org/software/scm/git/git-2.25.1.tar.xz")
+ (uri "mirror://kernel.org/software/scm/git/git-2.25.3.tar.xz")
(sha256
- (base32 "09lzwa183nblr6l8ib35g2xrjf9wm9yhk3szfvyzkwivdv69c9r2"))))
+ (base32 "0yvr97cl0dvj3fwblq1mb0cp97v8hrn9l98p8b1jx8815mbsnz9h"))))
("openssl" ,openssl)
("groff" ,groff)
("python" ,python)
@@ -1934,7 +1952,7 @@ from Subversion to any supported Distributed Version Control System (DVCS).")
(define-public tig
(package
(name "tig")
- (version "2.5.0")
+ (version "2.5.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1942,7 +1960,7 @@ from Subversion to any supported Distributed Version Control System (DVCS).")
version "/tig-" version ".tar.gz"))
(sha256
(base32
- "1x5famvvs93ih7sr11x7m33dksb1k7zs1s3c4zkyf0cjmxkpqlzz"))))
+ "0r4y9hyvpkplaxrzslws3asz652d83qh3bjwvmp8assga8s5s3ah"))))
(build-system gnu-build-system)
(native-inputs
`(("asciidoc" ,asciidoc)
@@ -1956,8 +1974,8 @@ from Subversion to any supported Distributed Version Control System (DVCS).")
(add-after 'install 'install-doc
(lambda _
(invoke "make" "install-doc"))))
- #:tests? #f)) ; tests require access to /dev/tty
- ;; #:test-target "test"))
+ #:test-target "test"
+ #:tests? #f)) ; tests require access to /dev/tty
(home-page "https://jonas.github.io/tig/")
(synopsis "Ncurses-based text user interface for Git")
(description