summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 514dfe7ab7..74f26c03f9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1320,14 +1320,14 @@ control to Git repositories.")
(define-public mercurial
(package
(name "mercurial")
- (version "5.2.1")
+ (version "5.3.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.mercurial-scm.org/"
"release/mercurial-" version ".tar.gz"))
(sha256
(base32
- "1pxkd37b0a1mi2zakk1hi122lgz1ffy2fxdnbs8acwlqpw55bc8q"))))
+ "1nbjpzjrzgql4hrvslpxwbcgn885ikq6ba1yb4w6p78rw9nzkhgp"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1369,7 +1369,8 @@ control to Git repositories.")
;; The following inputs are only needed to run the tests.
(native-inputs
`(("python-nose" ,python-nose)
- ("unzip" ,unzip)))
+ ("unzip" ,unzip)
+ ("which" ,which)))
(home-page "https://www.mercurial-scm.org/")
(synopsis "Decentralized version control system")
(description