summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index db3e9f1768..346f9753a8 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -112,14 +112,14 @@ as well as the classic centralized workflow.")
;; Keep in sync with 'git-manpages'!
(package
(name "git")
- (version "2.7.4")
+ (version "2.8.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "0ys55v2xrhzj74jrrqx75xpr458klnyxshh8d8swfpp0zgg79rfy"))))
+ "14dafk7rz8cy2z5b92yf009qf4pc70s0viwq7hxsgd4898knr3kx"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -292,7 +292,7 @@ everything from small to very large projects with speed and efficiency.")
version ".tar.xz"))
(sha256
(base32
- "09ffk5c0dl1xg7xcvr0kadhspx4fr2spmlmcajzfycmap0ddhkyh"))))
+ "1ilbi4xdn77a5yrjyrcx0nap0j4raw3h1fr0k32zs9y35c6f29cx"))))
(build-system trivial-build-system)
(arguments
'(#:modules ((guix build utils))
@@ -479,7 +479,7 @@ will work.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/nvie/gitflow/")
- (commit "15aab26")))
+ (commit "15aab26490facf285acef56cb5d61025eacb3a69")))
(sha256
(base32
"01fs97q76fdfnvmrh2cyjhywcs3pykf1dg58sy0frflnsdzs6prx"))))
@@ -513,10 +513,10 @@ lot easier.")
(license bsd-2)))
(define-public git-test-sequence
- (let ((commit "48e5a2f"))
+ (let ((commit "48e5a2f5a13a5f30452647237e23362b459b9c76"))
(package
(name "git-test-sequence")
- (version (string-append "20140312." commit))
+ (version (string-append "20140312." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -851,8 +851,8 @@ masters from remote CVS hosts.")
"094pjwshvazlgagc254in2xvrp93vhcj0kb5ms17qs7sch99x9z2"))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
- ("inetutils" ,inetutils) ; for `hostname', used in the tests
- ("emacs" ,emacs-no-x))) ; for `ctags'
+ ("inetutils" ,inetutils))) ; for `hostname', used in the tests
+ (native-inputs `(("emacs" ,emacs-minimal))) ; for `ctags'
(home-page "http://www.gnu.org/software/vc-dwim/")
(synopsis "Version-control-agnostic ChangeLog diff and commit tool")
(description