summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm106
1 files changed, 90 insertions, 16 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0b70d545b9..94339012f5 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -4,8 +4,8 @@
;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
@@ -29,7 +29,7 @@
#:use-module ((guix licenses)
#:select (asl2.0 bsd-2
gpl1+ gpl2 gpl2+ gpl3+ lgpl2.1
- x11-style))
+ public-domain x11-style))
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
@@ -38,7 +38,6 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
- #:use-module (guix build utils)
#:use-module (gnu packages apr)
#:use-module (gnu packages autotools)
#:use-module (gnu packages asciidoc)
@@ -113,14 +112,14 @@ as well as the classic centralized workflow.")
;; Keep in sync with 'git-manpages'!
(package
(name "git")
- (version "2.7.3")
+ (version "2.7.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1di96q86fq3pdn5d5v4fw9vf58gha5i9b3r880mxlh275n8ngi49"))))
+ "0ys55v2xrhzj74jrrqx75xpr458klnyxshh8d8swfpp0zgg79rfy"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -292,7 +291,7 @@ everything from small to very large projects with speed and efficiency.")
version ".tar.xz"))
(sha256
(base32
- "0va9j0q9h44jqih38h4cmhvbmjppqq7zbiq70220m7hsqqkq824z"))))
+ "09ffk5c0dl1xg7xcvr0kadhspx4fr2spmlmcajzfycmap0ddhkyh"))))
(build-system trivial-build-system)
(arguments
'(#:modules ((guix build utils))
@@ -681,14 +680,14 @@ property manipulation.")
(define-public subversion
(package
(name "subversion")
- (version "1.8.15")
+ (version "1.8.16")
(source (origin
(method url-fetch)
(uri (string-append "http://archive.apache.org/dist/subversion/"
"subversion-" version ".tar.bz2"))
(sha256
(base32
- "0b68rjy1sjd66nqcswrm1bhda3vk2ngkgs6drcanmzbcd3vs366g"))))
+ "0imkxn25n6sbcgfldrx4z29npjprb1lxjm5fb89q4297161nx3zi"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after
@@ -896,8 +895,8 @@ large, complex patch files.")
(sha256
(base32
"0bkw6fjh20ppvn54smv05461lm1vcwvn02avx941c4acafmkl1cm"))
- (patches (list (search-patch "cssc-gets-undeclared.patch")
- (search-patch "cssc-missing-include.patch")))))
+ (patches (search-patches "cssc-gets-undeclared.patch"
+ "cssc-missing-include.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases (alist-cons-before
@@ -940,11 +939,11 @@ accessed and migrated on modern systems.")
(sha256
(base32
"18s86ssarfmc4l17gbpzybca29m5wa37cbaimdji8czlcry3mcjl"))
- (patches (list (search-patch "aegis-perl-tempdir1.patch")
- (search-patch "aegis-perl-tempdir2.patch")
- (search-patch "aegis-test-fixup-1.patch")
- (search-patch "aegis-test-fixup-2.patch")
- (search-patch "aegis-constness-error.patch")))))
+ (patches (search-patches "aegis-perl-tempdir1.patch"
+ "aegis-perl-tempdir2.patch"
+ "aegis-test-fixup-1.patch"
+ "aegis-test-fixup-2.patch"
+ "aegis-constness-error.patch"))))
(build-system gnu-build-system)
(inputs
`(("e2fsprogs" ,e2fsprogs)
@@ -1125,3 +1124,78 @@ Mercurial, Bazaar, Darcs, CVS, Fossil, and Veracity.")
"This package allows you to use your hubic account as a \"special
repository\" with git-annex.")
(license gpl3+)))
+
+(define-public fossil
+ (package
+ (name "fossil")
+ (version "1.34")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Upstream source affected by
+ ;; http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20962
+ (uri (string-append
+ "https://web.archive.org/web/20160402202958/"
+ "https://www.fossil-scm.org/download/fossil-src-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "17x4vgjcfihwmq195qg32irp50panvjqfpvhqydfvv4ghwzbi9jk"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Commit 0a2ebe57 on 2015-08-03 18:35:53 changed output formatting
+ ;; for some commands, but affected tests were not updated. Use
+ ;; substitute here, which is more concise than patching.
+ (substitute* "test/clean.test"
+ (("NEW ") "NEW "))
+ (substitute* '("test/revert.test" "test/mv-rm.test")
+ (("REVERTED:") "REVERT ")
+ (("DELETE:") "DELETE ")
+ (("UNMANAGE:") "UNMANAGE "))
+ ;; Fix use of __DATE__ and __TIME__
+ (substitute* "src/main.c"
+ (("Compiled on %s %s") "Compiled")
+ (("__DATE__, __TIME__, ") ""))
+ #t))
+ (patches (list (search-patch "fossil-test-fixes.patch")))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("tcl" ,tcl) ;for configuration only
+ ("which" ,which) ;for tests only
+ ("ed" ,ed))) ;ditto
+ (inputs
+ `(("openssl" ,openssl)
+ ("zlib" ,zlib)
+ ("sqlite" ,sqlite)))
+ (arguments
+ `(#:configure-flags (list "--with-openssl=auto"
+ "--disable-internal-sqlite")
+ #:test-target "test"
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs (configure-flags '())
+ #:allow-other-keys)
+ ;; The 'configure' script is not an autoconf script and
+ ;; chokes on unrecognized options.
+ (zero? (apply system*
+ "./configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out"))
+ configure-flags))))
+ (add-before 'check 'test-setup
+ (lambda _
+ (setenv "USER" "guix")
+ (setenv "TZ" "UTC")
+ ;; Fixing the th1 test would require many backports, so
+ ;; just disable for now.
+ (delete-file "test/th1.test")
+ #t)))))
+ (home-page "https://fossil-scm.org")
+ (synopsis "Software configuration management system")
+ (description
+ "Fossil is a distributed source control management system which supports
+access and administration over HTTP CGI or via a built-in HTTP server. It has
+a built-in wiki, built-in file browsing, built-in tickets system, etc.")
+ (license (list public-domain ;src/miniz.c, src/shell.c
+ bsd-2))))