summaryrefslogtreecommitdiff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 14f45db9be..f1584c896a 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -32,7 +32,7 @@
(define-public valgrind
(package
(name "valgrind")
- (version "3.13.0")
+ (version "3.14.0")
(source (origin
(method url-fetch)
(uri (list (string-append "http://www.valgrind.org/downloads"
@@ -41,9 +41,8 @@
"/valgrind-" version ".tar.bz2")))
(sha256
(base32
- "0fqc3684grrbxwsic1rc5ryxzxmigzjx9p5vf3lxa37h0gpq0rnp"))
- (patches (search-patches "valgrind-enable-arm.patch"
- "valgrind-glibc-compat.patch"))))
+ "19ds42jwd89zrsjb94g7gizkkzipn8xik3xykrpcqxylxyzi2z03"))
+ (patches (search-patches "valgrind-enable-arm.patch"))))
(build-system gnu-build-system)
(outputs '("doc" ;16 MB
"out"))
@@ -79,11 +78,7 @@
tools. There are Valgrind tools that can automatically detect many memory
management and threading bugs, and profile your programs in detail. You can
also use Valgrind to build new tools.")
- (license gpl2+)
-
- ;; Building VEX on mips64el-linux fails with "opcode not supported on this
- ;; processor: mips3".
- (supported-systems (delete "mips64el-linux" %supported-systems))))
+ (license gpl2+)))
(define-public valgrind-3.15
(package