summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 92644fed2e..6f26f404be 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -39,14 +39,14 @@
(define-public tor
(package
(name "tor")
- (version "0.2.8.11")
+ (version "0.2.9.8")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
- "1cvaviamvmajzpdgjn2k1rk3g9ywl1c4ygs5157gvnkyl6zs1pks"))))
+ "0sklgmx4nikcfhqd606kvpwy1l8840w24ikli1xjjx25739k7pgv"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2))) ; for tests
@@ -54,9 +54,6 @@
`(("zlib" ,zlib)
("openssl" ,openssl)
("libevent" ,libevent)))
-
- ;; TODO: Recommend `torsocks' since `torify' needs it.
-
(home-page "https://www.torproject.org/")
(synopsis "Anonymous network router to improve privacy on the Internet")
(description
@@ -66,7 +63,12 @@ somebody watching your Internet connection from learning what sites you
visit, and it prevents the sites you visit from learning your physical
location. Tor works with many of your existing applications, including
web browsers, instant messaging clients, remote login, and other
-applications based on the TCP protocol.")
+applications based on the TCP protocol.
+
+To @code{torify} applications (to take measures to ensure that an application,
+which has not been designed for use with Tor such as ssh, will use only Tor for
+internet connectivity, and also ensures that there are no leaks from DNS, UDP or
+the application layer) you need to install @code{torsocks}.")
(license bsd-3)))
(define-public torsocks