summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 04dbc410ca..8d786b452a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1983,6 +1983,39 @@ recent classes such as powerdot or beamer, both of which are tuned to
21st-century presentation styles.")
(license license:lppl1.2+)))
+(define-public texlive-latex-trimspaces
+ (package
+ (name "texlive-latex-trimspaces")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "trimspaces"))
+ (sha256
+ (base32
+ "0da00lb32am4g63mn96625wg48p3pj3spx79lajrk17d549apwqa"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/trimspaces"
+ #:tex-format "latex"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-bug
+ (lambda _
+ ;; The "ins" file refers to the wrong source file.
+ (substitute* "trimspaces.ins"
+ (("pstool.tex") "trimspaces.tex"))
+ #t)))))
+ (inputs
+ `(("texlive-latex-filecontents" ,texlive-latex-filecontents)))
+ (home-page "http://www.ctan.org/pkg/trimspaces")
+ (synopsis "Trim spaces around an argument or within a macro")
+ (description
+ "This very short package allows you to expandably remove spaces around a
+token list (commands are provided to remove spaces before, spaces after, or
+both); or to remove surrounding spaces within a macro definition, or to define
+space-stripped macros.")
+ (license license:lppl)))
+
(define-public texlive-latex-capt-of
(package
(name "texlive-latex-capt-of")