summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm146
1 files changed, 103 insertions, 43 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 56a2ecb73f..87217f633a 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages file)
@@ -60,6 +61,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages linphone)
#:use-module (gnu packages linux)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -91,6 +93,35 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system qt))
+(define-public libilbc
+ (package
+ (name "libilbc")
+ (version "2.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/TimothyGu/libilbc.git")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32
+ "1j1pn1w1198qvdiq2hgv9hkyq2nqcvmfnwlgppac633idkjnjrqx"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No target
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Libre iLBC codec")
+ (description "LibiLBC is a packaging friendly copy of the iLBC codec from
+the WebRTC project. It provides a base for distribution packages and can be
+used as drop-in replacement for the non-free code from RFC 3591.")
+ (home-page "https://github.com/TimothyGu/libilbc")
+ (license license:bsd-3)))
+
(define-public spandsp
(package
(name "spandsp")
@@ -257,6 +288,37 @@ packet-manipulation library.")
(license license:gpl2+) ; plus runtime exception
(home-page "https://www.gnu.org/software/ccrtp/")))
+(define-public zrtpcpp
+ (package
+ (name "zrtpcpp")
+ (version "4.6.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/wernerd/ZRTPCPP.git")
+ (commit
+ (string-append "V" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32
+ "06vphvh4dgi7ah5qkq53wqvswv8l273x0xwbc447qmgvamm0x1vs"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No target
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ccrtp" ,ccrtp)
+ ("ucommon" ,ucommon)))
+ (synopsis "C++ Implementation of ZRTP protocol")
+ (description "GNU ZRTP C++ provides a library that adds ZRTP support to the
+GNU ccRTP stack and serves as library for other RTP stacks
+(PJSIP, GStreamer).")
+ (home-page "https://www.gnu.org/software/ccrtp/zrtp")
+ (license license:lgpl3+)))
(define-public osip
(package
@@ -593,59 +655,57 @@ Mumble consists of two applications for separate usage:
(package
(name "twinkle")
(version "1.10.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/LubosD/twinkle")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0s0gi03xwvzp02ah4q6j33r9jx9nbayr6dxlg2ck9pwbay1nq1hx"))))
- (build-system cmake-build-system)
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/LubosD/twinkle")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (patches
+ (search-patches "twinkle-bcg729.patch")) ; To support new BCG729 API.
+ (sha256
+ (base32
+ "0s0gi03xwvzp02ah4q6j33r9jx9nbayr6dxlg2ck9pwbay1nq1hx"))))
+ (build-system qt-build-system)
(arguments
- `(#:tests? #f ; no test target
- #:configure-flags '("-DWITH_SPEEX=On")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/twinkle")
- `("QT_PLUGIN_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/plugins"))
- '("qtbase" "qtdeclarative")))
- `("QML2_IMPORT_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/qml"))
- '("qtdeclarative" "qtquickcontrols"))))
- #t))))))
+ `(#:tests? #f ; no test target
+ #:configure-flags
+ (list
+ ;; FIX-ME: Make Twinkle compatible with libre version of iLBC.
+ ;; "-DWITH_ILBC=On" ; For iLBC Codec Support
+ "-DWITH_ZRTP=On" ; For ZRTP Support
+ "-DWITH_G729=On" ; For G729 Codec Support
+ "-DWITH_SPEEX=On"))) ; For Speex Codec Support
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
- ("readline" ,readline)
- ("file" ,file)
- ("ucommon" ,ucommon)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("bcg729" ,bcg729)
+ ("zrtpcpp" ,zrtpcpp)
("ccrtp" ,ccrtp)
+ ("file" ,file)
+ ("libilbc" ,libilbc)
+ ("libsndfile" ,libsndfile)
("libxml2" ,libxml2)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtquickcontrols" ,qtquickcontrols)
+ ("readline" ,readline)
("speex" ,speex)
("speexdsp" ,speexdsp)
- ("libsndfile" ,libsndfile)
- ("alsa-lib" ,alsa-lib)
- ("qttools" ,qttools)))
- (inputs
- `(("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("qtquickcontrols" ,qtquickcontrols)))
- (home-page "http://twinkle.dolezel.info/")
+ ("ucommon" ,ucommon)))
(synopsis "Softphone for voice over IP and instant messaging")
(description "Twinkle is a softphone for your voice over IP and instant
-messaging communcations using the SIP protocol. You can use it for direct IP
-phone to IP phone communication or in a network using a SIP proxy to route your
-calls and messages")
+messaging communcations using the SIP protocol. You can use it for direct
+IP phone to IP phone communication or in a network using a SIP proxy to route
+your calls and messages.")
+ (home-page "http://twinkle.dolezel.info/")
(license license:gpl2+)))
(define-public pjproject