summaryrefslogtreecommitdiff
path: root/gnu/packages/system.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/system.scm')
-rw-r--r--gnu/packages/system.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index a5d2e67585..9c06e6b61e 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -28,6 +28,8 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages linux)
#:use-module (gnu packages guile)
+ #:use-module ((gnu packages gettext)
+ #:renamer (symbol-prefix-proc 'g:))
#:use-module ((gnu packages base)
#:select (tar))
#:use-module ((gnu packages compression)
@@ -74,6 +76,7 @@ is based on GNU Guile.")
"1b4hfqv23l87cb37fxwzfk2sgspkyxpr3ig2hsd23hr6mm982j7z"))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; There are no tests.
+ (native-inputs `(("gettext" ,g:gettext)))
(home-page "http://projects.gw-computing.net/projects/dfc")
(synopsis "Display file system space usage using graphs and colors")
(description
@@ -318,3 +321,25 @@ programs and scripts. At the same time, it is a feature-rich network debugging
and exploration tool, since it can create almost any kind of connection you
would need and has several interesting built-in capabilities.")
(license gpl2+)))
+
+(define-public alive
+ (package
+ (name "alive")
+ (version "2.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/alive/alive-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1vrzg51ai68x9yld7vbgl58sxaw5qpx8rbakwcxn4cqq6vpxj38j"))))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags '("alive_cv_nice_ping=yes")))
+ (inputs `(("guile" ,guile-2.0)
+ ("inetutils" ,inetutils)))
+ (home-page "http://www.gnu.org/software/alive/")
+ (synopsis "Autologin and keep-alive daemon")
+ (description
+ "GNU Alive sends periodic pings to a server, generally to keep a
+connection alive.")
+ (license gpl3+)))