summaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 7e0da38285..421e362cde 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
@@ -33,29 +33,29 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
- #:use-module (gnu packages databases)
#:use-module (gnu packages golang)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages perl)
- #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
#:use-module (gnu packages rsync)
#:use-module (gnu packages selinux)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages tls))
(define-public owncloud-client
(package
(name "owncloud-client")
- (version "2.4.1")
+ (version "2.5.1.10973")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.owncloud.com/desktop/stable/"
"owncloudclient-" version ".tar.xz"))
(sha256
- (base32 "08xayz0alvypwa1bjmw1rmh4m3sclld4yq7kcbf264983icawqj4"))
+ (base32 "19x4rbnqg7f7hspz1xy86b1q51q1n5y7yvq8kqc1m64n2r2s3srk"))
(patches (search-patches "owncloud-disable-updatecheck.patch"))
(modules '((guix build utils)))
(snippet
@@ -109,14 +109,14 @@ silently and reliably flow across to every other.")
(version "0.5.8")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/sieren/QSyncthingTray/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sieren/QSyncthingTray")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1024778ml7q62ziqm4d22z5sc1715l34846pwfyzfpcyl32qlhpz"))))
+ "1n9g4j7qznvg9zl6x163pi9f7wsc3x6q76i33psnm7x2v1i22x5w"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
@@ -128,12 +128,10 @@ silently and reliably flow across to every other.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
(install-file "QSyncthingTray" bin)
- (install-file (string-append
- "../QSyncthingTray-"
- ,(package-version qsyncthingtray)
- "/resources/images/Icon1024.png")
- (string-append
- out "/share/pixmaps/QSyncthingTray.png"))
+ (mkdir-p (string-append out "/share/pixmaps"))
+ (copy-file "../source/resources/images/Icon1024.png"
+ (string-append
+ out "/share/pixmaps/QSyncthingTray.png"))
#t))))
#:tests? #f)) ; no test target
(inputs