summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm153
1 files changed, 40 insertions, 113 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index b4de0e812b..6083ac18ee 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages sphinx)
@@ -567,14 +568,14 @@ also flexible enough to handle most nonstandard requirements.")
(define-public r-matrix
(package
(name "r-matrix")
- (version "1.2-17")
+ (version "1.2-18")
(source
(origin
(method url-fetch)
(uri (cran-uri "Matrix" version))
(sha256
(base32
- "1k1zf92ycqr7fz44w7bp1p354ww7jg0wm23ybb8dzmbg37qfchyv"))))
+ "06b1rc1vq65b271f2wpzhqkvhng8hwwnvjflzxkng50i52603zzp"))))
(properties `((upstream-name . "Matrix")))
(build-system r-build-system)
(propagated-inputs
@@ -692,14 +693,14 @@ analysis.")
(define-public r-survival
(package
(name "r-survival")
- (version "3.1-7")
+ (version "3.1-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "survival" version))
(sha256
(base32
- "1ij77bgfcjx29xkx5bck0sv4ybglpcmzzv9ilkinj8fqhhclbs8p"))))
+ "15fj4y8c107bwq22amx88r5hw7qndlcbr9sapzrpkpr7iqz3kkyf"))))
(build-system r-build-system)
(propagated-inputs
`(("r-matrix" ,r-matrix)))
@@ -803,13 +804,13 @@ effects of different types of color-blindness.")
(define-public r-digest
(package
(name "r-digest")
- (version "0.6.22")
+ (version "0.6.23")
(source
(origin
(method url-fetch)
(uri (cran-uri "digest" version))
(sha256
- (base32 "1qav52y1qmkg9j2g48mrl6bbjwhs0fs9dl55xb62lfkrihkappqh"))))
+ (base32 "18h5s8vkdcz2vhpsx6g3ig00zalrihr03skn95zw3lr2y56pafmp"))))
(build-system r-build-system)
;; Vignettes require r-knitr, which requires r-digest, so we have to
;; disable them and the tests.
@@ -848,30 +849,6 @@ functions of regression coefficients, and @code{epredict} methods that handle
non-estimable cases correctly.")
(license license:gpl2+)))
-(define-public r-pheatmap
- (package
- (name "r-pheatmap")
- (version "1.0.12")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "pheatmap" version))
- (sha256
- (base32
- "1hdh74az3vyzz6dqa311rhxdm74n46lyr03p862kn80p0kp9d7ap"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-gtable" ,r-gtable)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-scales" ,r-scales)))
- (home-page
- "https://cran.r-project.org/web/packages/pheatmap")
- (synopsis "Pretty heatmaps")
- (description
- "This package provides an implementation of heatmaps that offers more
-control over dimensions and appearance.")
- (license license:gpl2+)))
-
(define-public r-labeling
(package
(name "r-labeling")
@@ -1108,32 +1085,6 @@ the input of another.")
using just two functions: melt and dcast (or acast).")
(license license:expat)))
-(define-public r-scales
- (package
- (name "r-scales")
- (version "1.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "scales" version))
- (sha256
- (base32 "0353dkh3d7x78463c6ds80hcml59lrqwr8rlv82a8dnkxla4l7qc"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-labeling" ,r-labeling)
- ("r-munsell" ,r-munsell)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-rcpp" ,r-rcpp)
- ("r-r6" ,r-r6)
- ("r-viridislite" ,r-viridislite)))
- (home-page "https://github.com/hadley/scales")
- (synopsis "Scale functions for visualization")
- (description
- "This package provides graphical scales that map data to aesthetics, and
-provides methods for automatically determining breaks and labels for axes and
-legends.")
- (license license:expat)))
-
(define-public r-ggplot2
(package
(name "r-ggplot2")
@@ -1604,13 +1555,13 @@ R packages that praise their users.")
(define-public r-testthat
(package
(name "r-testthat")
- (version "2.3.0")
+ (version "2.3.1")
(source (origin
(method url-fetch)
(uri (cran-uri "testthat" version))
(sha256
(base32
- "0qlajfgm3zjrmladwcm0xzw8zp2431zz2asa2w7lpg7zl6ymvz29"))))
+ "0m8xchdpgn9iwj6gb2qw46zr85v9zf1gkbr9nnahmy5sp1s9bbky"))))
(build-system r-build-system)
(propagated-inputs
`(("r-cli" ,r-cli)
@@ -1656,13 +1607,13 @@ defined in different packages.")
(define-public r-rlang
(package
(name "r-rlang")
- (version "0.4.1")
+ (version "0.4.2")
(source (origin
(method url-fetch)
(uri (cran-uri "rlang" version))
(sha256
(base32
- "122hhc7pdri8wkjmk37y71m4h1gmdzaqcfdizfdjg1bhy935i10k"))))
+ "0fczcp17kaz3s4p0nd4126bppwl20vpxfybhsndpcky9h75wklgv"))))
(build-system r-build-system)
(home-page "http://rlang.tidyverse.org")
(synopsis "Functions for base types, core R and Tidyverse features")
@@ -2081,13 +2032,13 @@ jackknifed confidence intervals are available for most estimates.")
(define-public r-rversions
(package
(name "r-rversions")
- (version "2.0.0")
+ (version "2.0.1")
(source (origin
(method url-fetch)
(uri (cran-uri "rversions" version))
(sha256
(base32
- "0mkg9zrjxlbwqzijiysivrs523x48syqj30xdfp88clpkqfk435m"))))
+ "1ic6sxnyya24d5xsxjg3fba73fhya9fhs0kaf66yha6nwxj1zv2i"))))
(build-system r-build-system)
(propagated-inputs
`(("r-curl" ,r-curl)
@@ -2309,13 +2260,13 @@ tables, autolinks and strikethrough text.")
(define-public r-roxygen2
(package
(name "r-roxygen2")
- (version "7.0.0")
+ (version "7.0.2")
(source (origin
(method url-fetch)
(uri (cran-uri "roxygen2" version))
(sha256
(base32
- "13sani3y9ql56cvja8pfjpwsbq8pismc52ns1cq1zgi0jycgqja5"))))
+ "162xag27hwwyadfwm5zpyy15nxwhw2vbhwapx3jmi9cfyryr68sq"))))
(build-system r-build-system)
(propagated-inputs
`(("r-brew" ,r-brew)
@@ -2665,13 +2616,13 @@ vectors.")
(define-public r-catools
(package
(name "r-catools")
- (version "1.17.1.2")
+ (version "1.17.1.3")
(source (origin
(method url-fetch)
(uri (cran-uri "caTools" version))
(sha256
(base32
- "0svj31y7h8vimvliygmmbl7pk850qk80k1vn38mlcxsnmcpm9k39"))))
+ "04m7vbydxb1nipday97w29p2miykyzxw572j9lda6jxmmp2kb1yp"))))
(properties `((upstream-name . "caTools")))
(build-system r-build-system)
(propagated-inputs
@@ -2711,13 +2662,13 @@ certain criterion, e.g., it contains a certain regular file.")
(define-public r-rmarkdown
(package
(name "r-rmarkdown")
- (version "1.17")
+ (version "1.18")
(source
(origin
(method url-fetch)
(uri (cran-uri "rmarkdown" version))
(sha256
- (base32 "18dj6nr1m79pv1pv9w2n0rhiidwqjb2w8w1rnpcwijwbz4i8d3k2"))))
+ (base32 "0fykzbb5kjsqc8v6gjcdma7rmq0gailp30qij6plgna4d8nhjw3w"))))
(properties `((upstream-name . "rmarkdown")))
(build-system r-build-system)
(propagated-inputs
@@ -2826,13 +2777,13 @@ a column in data frame.")
(define-public r-rsqlite
(package
(name "r-rsqlite")
- (version "2.1.2")
+ (version "2.1.3")
(source (origin
(method url-fetch)
(uri (cran-uri "RSQLite" version))
(sha256
(base32
- "1inrhap5cs0wry2jbw42fx9wwxb3qdzlpy0ba4f6a29bs8jx9nk6"))))
+ "0c5s67s8w4q6p57rnh14n4gcmymyardg8lhnrdlimmjcfawj15h7"))))
(properties `((upstream-name . "RSQLite")))
(build-system r-build-system)
(propagated-inputs
@@ -3256,14 +3207,13 @@ analysis of large sparse or dense matrices.")
(define-public r-glmnet
(package
(name "r-glmnet")
- (version "3.0")
+ (version "3.0-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "glmnet" version))
(sha256
- (base32
- "1fwspkxbsx7jy5h8zcdl0q8xsbj7svjjbcmg5lfpxdsgyyww46v7"))))
+ (base32 "04wa926mnss53p1fhx0mjgxnmwmmqls12sc0sy7w09kbmyqa3fq7"))))
(build-system r-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
@@ -3383,14 +3333,14 @@ Stochastic Neighbor Embedding using a Barnes-Hut implementation.")
(define-public r-e1071
(package
(name "r-e1071")
- (version "1.7-2")
+ (version "1.7-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "e1071" version))
(sha256
(base32
- "0lipj692rjjw8rrhqh2k9i5dh8y2sjrw9q53rwm32irhx2f2j73j"))))
+ "0pf2pjb590z0jikgv1037xcp7dq06mg3dzmyffjw6gk7dd9blbdv"))))
(build-system r-build-system)
(propagated-inputs
`(("r-class" ,r-class)))
@@ -4884,14 +4834,14 @@ analysis} (PCA) by projection pursuit.")
(define-public r-rrcov
(package
(name "r-rrcov")
- (version "1.4-7")
+ (version "1.4-9")
(source
(origin
(method url-fetch)
(uri (cran-uri "rrcov" version))
(sha256
(base32
- "14zjyqcdiqx6js99nx5s8hmyx564ixy2d8s6i7wa50xmx368rl6b"))))
+ "11zvxidlb1pr2j5dzvmbjqdgsmmicsq8ppjf5wcfykfyf2fkcmz7"))))
(build-system r-build-system)
(propagated-inputs
`(("r-cluster" ,r-cluster)
@@ -5020,14 +4970,13 @@ groupings.")
(define-public r-vgam
(package
(name "r-vgam")
- (version "1.1-1")
+ (version "1.1-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "VGAM" version))
(sha256
- (base32
- "0lnsqx3q3k0c7sj8gj0n6shn2fyxwrh8xph8h1r1i23ybbb2n6fy"))))
+ (base32 "0kyan3a4ys2xbg9kf167cyf1gk7g963id62cjm2ij4i7y4wi61zq"))))
(properties `((upstream-name . "VGAM")))
(build-system r-build-system)
(inputs
@@ -5088,14 +5037,14 @@ based on an interface to Fortran implementations by M. J. D. Powell.")
(define-public r-rcppeigen
(package
(name "r-rcppeigen")
- (version "0.3.3.5.0")
+ (version "0.3.3.7.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "RcppEigen" version))
(sha256
(base32
- "01bz41c29591ybzqn4z88ss036ai3anh9figryvmfpqcfwbszip5"))))
+ "1b78qcjim0n9klgkr82n794d6bj9r9f33g0kcsszsns2hir65sk2"))))
(properties `((upstream-name . "RcppEigen")))
(build-system r-build-system)
(propagated-inputs
@@ -5268,14 +5217,13 @@ bootstrap test for generalized linear mixed models.")
(define-public r-cardata
(package
(name "r-cardata")
- (version "3.0-2")
+ (version "3.0-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "carData" version))
(sha256
- (base32
- "152lfgaspgx6x2wzdb5p3zv6r87a0d2pg10h6fjmdr613kzlwp1v"))))
+ (base32 "0cg2yxzn0pdjqykr60my1fzpfkqac21fll5hv3m9w5c9sayq8swq"))))
(properties `((upstream-name . "carData")))
(build-system r-build-system)
(home-page "https://r-forge.r-project.org/projects/car/")
@@ -5288,14 +5236,13 @@ Companion to Applied Regression, Third Edition, Sage.")
(define-public r-car
(package
(name "r-car")
- (version "3.0-4")
+ (version "3.0-5")
(source
(origin
(method url-fetch)
(uri (cran-uri "car" version))
(sha256
- (base32
- "1mhfxrb62yanaz36f4n38p9hhnqbs5b19k0864w4ja1ccgh3nl3f"))))
+ (base32 "0w7fm81pn0wqrwzbjyddnrkpjl8gavg7ijh7rab9f21rkgkzgm3y"))))
(build-system r-build-system)
(propagated-inputs
`(("r-abind" ,r-abind)
@@ -5709,20 +5656,20 @@ inferring an appropriate positioning method.")
(license license:gpl3)))
(define-public r-catterplots
- (let ((commit "40063ec57f9515d231508f135ca0ec769614efb9")
- (revision "2"))
+ (let ((commit "ae17cd5e49ddda4ecfe0eba8a4c21df8c88e72c4")
+ (revision "3"))
(package
(name "r-catterplots")
- (version (string-append "0-" revision "." (string-take commit 9)))
+ (version (git-version "0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/Gibbsdavidl/CatterPlots.git")
(commit commit)))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1wl80pgbz8d9kfpffvkh439hlgz2qldm9m75wqjfrgrg8lcjzrxg"))))
+ "0qa8liylffpxgdg8xcgjar5dsvczqhn3akd4w35113hnyg1m4xyg"))))
(build-system r-build-system)
(propagated-inputs
`(("r-png" ,r-png)))
@@ -5764,26 +5711,6 @@ table made by the command @code{show256Colors()}. You can also set the colors
to any arbitrary string. In this case, it is up to you to set valid values.")
(license license:gpl3+)))
-(define-public r-txtplot
- (package
- (name "r-txtplot")
- (version "1.0-3")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "txtplot" version))
- (sha256
- (base32
- "1949ab1bzvysdb79g8x1gaknj0ih3d6g63pv9512h5m5l3a6c31h"))))
- (build-system r-build-system)
- (home-page "https://cran.r-project.org/web/packages/txtplot/")
- (synopsis "Text-based plotting")
- (description "This package provides functions to produce rudimentary ASCII
-graphics directly in the terminal window. This package provides a basic
-plotting function (and equivalents of curve, density, acf and barplot) as well
-as a boxplot function.")
- (license license:lgpl3+)))
-
(define-public python-rpy2
;; We need to take this changeset instead of the RELEASE_3_0_4 tag, because
;; it fixes a regression when using ggplot 3.2.0.