summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm27
1 files changed, 19 insertions, 8 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index e3af517997..bfcf3d39ef 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2018 Manuel Graf <graf@init.at>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -167,7 +167,15 @@ a server that supports the SSH-2 protocol.")
"--with-libedit"
;; Enable PAM support in sshd.
- "--with-pam")
+ "--with-pam"
+
+ ;; "make install" runs "install -s" by default,
+ ;; which doesn't work for cross-compiled binaries
+ ;; because it invokes 'strip' instead of
+ ;; 'TRIPLET-strip'. Work around this.
+ ,,@(if (%current-target-system)
+ '("--disable-strip")
+ '()))
#:phases
(modify-phases %standard-phases
@@ -293,8 +301,8 @@ Additionally, various channel-specific options can be negotiated.")
("texinfo" ,texinfo)
("pkg-config" ,pkg-config)
("which" ,which)
- ("guile" ,guile-2.2))) ;needed when cross-compiling.
- (inputs `(("guile" ,guile-2.2)
+ ("guile" ,guile-3.0))) ;needed when cross-compiling.
+ (inputs `(("guile" ,guile-3.0)
("libssh" ,libssh)
("libgcrypt" ,libgcrypt)))
(synopsis "Guile bindings to libssh")
@@ -314,16 +322,19 @@ libssh library.")
(inputs `(("guile" ,guile-2.0)
,@(alist-delete "guile" (package-inputs guile-ssh))))))
-(define-public guile3.0-ssh
+(define-public guile2.2-ssh
(package
(inherit guile-ssh)
- (name "guile3.0-ssh")
+ (name "guile2.2-ssh")
(native-inputs
- `(("guile" ,guile-next) ;needed when cross-compiling.
+ `(("guile" ,guile-2.2) ;needed when cross-compiling.
,@(alist-delete "guile" (package-native-inputs guile-ssh))))
- (inputs `(("guile" ,guile-next)
+ (inputs `(("guile" ,guile-2.2)
,@(alist-delete "guile" (package-inputs guile-ssh))))))
+(define-public guile3.0-ssh
+ (deprecated-package "guile3.0-ssh" guile-ssh))
+
(define-public corkscrew
(package
(name "corkscrew")