summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index fb3b11ba2d..521be54c49 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -86,6 +86,10 @@
(modify-phases %standard-phases
(add-after 'unpack 'autogen
(lambda _
+ ;; Build without '-Werror', in particular to avoid errors due
+ ;; to the use of the deprecated 'libusb_set_debug' function.
+ (substitute* "configure.ac"
+ (("-Werror") ""))
(zero? (system* "autoreconf" "-vfi")))))))
(synopsis "Tools for sending USB device traffic over a network")
(description "Usbredir is a network protocol for sending USB device traffic