summaryrefslogtreecommitdiff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 5fdf2cdbd8..8ee6fbfdc4 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,15 +33,20 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base) ;for 'which'
+ #:use-module (gnu packages bison)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages emacs)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils))
@@ -471,3 +477,64 @@ The system is written in C++ and uses the Edinburgh Speech Tools Library for
low level architecture and has a Scheme (SIOD) based command interpreter for
control.")
(license (license:non-copyleft "file://COPYING"))))
+
+(define-public sphinxbase
+ (package
+ (name "sphinxbase")
+ (version "5prealpha")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/cmusphinx/"
+ "sphinxbase/" version "/"
+ "sphinxbase-" version ".tar.gz"))
+ (sha256
+ (base32 "0vr4k8pv5a8nvq9yja7kl13b5lh0f9vha8fc8znqnm8bwmcxnazp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-tests? #f)) ;tests fail otherwise
+ (native-inputs
+ `(("bison" ,bison)
+ ("doxygen" ,doxygen)
+ ("perl" ,perl) ;for tests
+ ("python" ,python)
+ ("swig" ,swig)))
+ (inputs
+ `(("pulseaudio" ,pulseaudio)))
+ (home-page "https://cmusphinx.github.io/")
+ (synopsis "Support library required by Pocketsphinx and Sphinxtrain")
+ (description "This package contains the basic libraries shared by
+the CMU Sphinx trainer and all the Sphinx decoders (Sphinx-II,
+Sphinx-III, and PocketSphinx), as well as some common utilities for
+manipulating acoustic feature and audio files.")
+ (license license:bsd-4)))
+
+(define-public pocketsphinx
+ (package
+ (name "pocketsphinx")
+ (version "5prealpha")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/cmusphinx/"
+ "pocketsphinx/" version "/"
+ "pocketsphinx-" version ".tar.gz"))
+ (sha256
+ (base32 "1n9yazzdgvpqgnfzsbl96ch9cirayh74jmpjf7svs4i7grabanzg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("perl" ,perl) ;for tests
+ ("python" ,python)
+ ("swig" ,swig)))
+ (inputs
+ `(("gstreamer" ,gstreamer)
+ ("libcap" ,libcap)
+ ("pulseaudio" ,pulseaudio)
+ ("sphinxbase" ,sphinxbase)))
+ (home-page "https://cmusphinx.github.io/")
+ (synopsis "Recognizer library written in C")
+ (description "PocketSphinx is one of Carnegie Mellon University's
+large vocabulary, speaker-independent continuous speech recognition
+engine.")
+ (license license:bsd-2)))