summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm41
1 files changed, 28 insertions, 13 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index f03d7c4a9d..1f076999cb 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 ng0 <ng0@infotropique.org>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
@@ -88,14 +88,19 @@ direct descendant of NetBSD's Almquist Shell (@command{ash}).")
(define-public fish
(package
(name "fish")
- (version "2.6.0")
+ (version "2.7.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://fishshell.com/files/"
- version "/fish-" version ".tar.gz"))
+ (uri
+ (list
+ (string-append "https://fishshell.com/files/"
+ version "/fish-" version ".tar.gz")
+ (string-append "https://github.com/fish-shell/fish-shell/"
+ "releases/download/" version "/"
+ name "-" version ".tar.gz")))
(sha256
(base32
- "1yzx73kg5ng5ivhi68756sl5hpb8869110l9fwim6gn7f7bbprby"))
+ "1jvvm27hp46w0cia14lfz6161dkz8b935j1m7j38i7rgx75bfxis"))
(modules '((guix build utils)))
;; Don't try to install /etc/fish/config.fish.
(snippet
@@ -144,15 +149,15 @@ highlighting.")
(define-public fish-guix
(package
(name "fish-guix")
- (version "0.1.1")
+ (version "0.1.2.1")
(source
(origin
(method url-fetch)
- (uri (string-append "https://dist.infotropique.org/fish-guix/"
+ (uri (string-append "https://d.n0.is/releases/fish-guix/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0xi0j9lvzh43lrj82gz52n2cjln0i0pgayngrg4hy5w4449biy0z"))))
+ "0k71hcn7nr523w74jw2i68x52s9hv6vmasnvnn7yr3xxvzn4kqgf"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No checks.
@@ -161,11 +166,11 @@ highlighting.")
#:phases
(modify-phases %standard-phases
(delete 'configure)))) ; No configure script.
- (home-page "https://www.infotropique.org/projects/fish-guix/")
+ (home-page "https://n0.is/s/fish-guix/")
(synopsis "Fish completions for Guix")
(description
"Fish-guix provides completions for Guix for users of the fish shell.")
- (license public-domain)))
+ (license bsd-3)))
(define-public rc
(package
@@ -312,7 +317,7 @@ history mechanism, job control and a C-like syntax.")
(define-public zsh
(package
(name "zsh")
- (version "5.2")
+ (version "5.4.2")
(source (origin
(method url-fetch)
(uri (list (string-append
@@ -323,7 +328,7 @@ history mechanism, job control and a C-like syntax.")
".tar.gz")))
(sha256
(base32
- "0dsr450v8nydvpk8ry276fvbznlrjgddgp7zvhcw4cv69i9lr4ps"))))
+ "1jdcfinzmki2w963msvsanv29vqqfmdfm4rncwpw0r3zqnrcsywm"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
#:phases
@@ -346,7 +351,17 @@ history mechanism, job control and a C-like syntax.")
"Test/B02typeset.ztst"
"Completion/Unix/Command/_init_d"
"Util/preconfig")
- (("/bin/sh") (which "sh")))))))))
+ (("/bin/sh") (which "sh"))))))
+ (add-before 'check 'patch-test
+ (lambda _
+ ;; In Zsh, `command -p` searches a predefined set of
+ ;; paths that don't exist in the build environment. See
+ ;; the assignment of 'path' in Src/init.c'
+ (substitute* "Test/A01grammar.ztst"
+ (("command -pv") "command -v")
+ (("command -p") "command ")
+ (("'command' -p") "'command' "))
+ #t)))))
(native-inputs `(("autoconf" ,autoconf)))
(inputs `(("ncurses" ,ncurses)
("pcre" ,pcre)