summaryrefslogtreecommitdiff
path: root/gnu/packages/serialization.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/serialization.scm')
-rw-r--r--gnu/packages/serialization.scm40
1 files changed, 11 insertions, 29 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 249b6f1af5..2bd1872bfd 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -260,34 +260,19 @@ that implements both the msgpack and msgpack-rpc specifications.")
(define-public yaml-cpp
(package
(name "yaml-cpp")
- (version "0.6.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/jbeder/yaml-cpp/archive/"
- "yaml-cpp-" version ".tar.gz"))
- (sha256
- (base32
- "01gxn7kc8pzyh4aadjxxzq8cignmbwmm9rfrsmgqfg9w2q75dn74"))))
+ (version "0.6.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbeder/yaml-cpp.git")
+ (commit (string-append "yaml-cpp-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ykkxzxcwwiv8l8r697gyqh1nl582krpvi7m7l6b40ijnk4pw30s"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'dont-install-gtest-libraries
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion
- (string-append out "/include")
- (delete-file-recursively "gtest")
- (delete-file-recursively "gmock"))
- (with-directory-excursion
- (string-append out "/lib")
- (for-each (lambda (file)
- (delete-file file))
- '("libgmock.so" "libgmock_main.so"
- "libgtest.so" "libgtest_main.so"))))
- #t)))))
+ '(#:configure-flags '("-DYAML_BUILD_SHARED_LIBS=ON")))
(native-inputs
`(("python" ,python)))
(home-page "https://github.com/jbeder/yaml-cpp")
@@ -524,6 +509,3 @@ game development and other performance-critical applications.")
(description "This package provides a Python wrapper library to the
Apache Arrow-based Feather binary columnar serialization data frame format.")
(license license:asl2.0)))
-
-(define-public python2-feather-format
- (package-with-python2 python-feather-format))