summaryrefslogtreecommitdiff
path: root/gnu/packages/security-token.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/security-token.scm')
-rw-r--r--gnu/packages/security-token.scm90
1 files changed, 90 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 6ff83ce5a4..9d9580ca7b 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,14 +32,20 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages autotools)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages docbook)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
#:use-module (gnu packages networking)
#:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages tex)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml))
@@ -202,3 +209,86 @@ one-time-password (OTP) YubiKey against Yubico’s servers. See the Yubico
website for more information about Yubico and the YubiKey.")
(home-page "https://developers.yubico.com/yubico-c-client/")
(license license:bsd-2)))
+
+(define-public opensc
+ (package
+ (name "opensc")
+ (version "0.17.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/OpenSC/OpenSC/releases/download/"
+ version "/opensc-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0043jh5g7q2lyd5vnb0akwb5y349isx7vbm9wqhlgav7d20wcwxy"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; By setting an absolute path here, we arrange for OpenSC to
+ ;; successfully dlopen libpcsclite.so.1 by default. The user can
+ ;; still override this if they want to, by specifying a custom OpenSC
+ ;; configuration file at runtime.
+ (add-after 'unpack 'set-default-libpcsclite.so.1-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libpcsclite (string-append (assoc-ref inputs "pcsc-lite")
+ "/lib/libpcsclite.so.1")))
+ (substitute* "configure"
+ (("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
+ (string-append
+ "DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))
+ #t))))))
+ (inputs
+ `(("readline" ,readline)
+ ("openssl" ,openssl)
+ ("pcsc-lite" ,pcsc-lite)
+ ("ccid" ,ccid)))
+ (native-inputs
+ `(("libxslt" ,libxslt)
+ ("docbook-xsl" ,docbook-xsl)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/OpenSC/OpenSC/wiki")
+ (synopsis "Tools and libraries related to smart cards")
+ (description
+ "OpenSC is a set of software tools and libraries to work with smart
+cards, with the focus on smart cards with cryptographic capabilities. OpenSC
+facilitate the use of smart cards in security applications such as
+authentication, encryption and digital signatures. OpenSC implements the PKCS
+#15 standard and the PKCS #11 API.")
+ (license license:lgpl2.1+)))
+
+(define-public yubico-piv-tool
+ (package
+ (name "yubico-piv-tool")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://developers.yubico.com/yubico-piv-tool/Releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1axa0lnky5gsc8yack6mpfbjh49z0czr1cv52gbgjnx2kcbpb0y1"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("perl" ,perl)
+ ("pcsc-lite" ,pcsc-lite)
+ ("openssl" ,openssl)))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("graphviz" ,graphviz)
+ ("check" ,check)
+ ("texlive-bin" ,texlive-bin)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://developers.yubico.com/yubico-piv-tool/")
+ (synopsis "Interact with the PIV application on a YubiKey")
+ (description
+ "The Yubico PIV tool is used for interacting with the Privilege and
+Identification Card (PIV) application on a YubiKey. With it you may generate
+keys on the device, import keys and certificates, create certificate requests,
+and other operations. It includes a library and a command-line tool.")
+ ;; The file ykcs11/pkcs11.h also declares an additional, very short free
+ ;; license for that one file. Please see it for details. The vast
+ ;; majority of files are licensed under bsd-2.
+ (license license:bsd-2)))