summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm109
1 files changed, 17 insertions, 92 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index fe01086a86..2e8cec8ffb 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,7 +35,6 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system haskell)
#:use-module (guix build-system trivial)
#:use-module (gnu packages audio)
#:use-module (gnu packages fcitx)
@@ -42,7 +42,6 @@
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages guile)
- #:use-module (gnu packages haskell)
#:use-module (gnu packages ibus)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
@@ -405,6 +404,22 @@ directory.")
(propagated-inputs
(propagated-inputs-with-sdl2 sdl-mixer))))
+(define-public sdl2-net
+ (package (inherit sdl-net)
+ (name "sdl2-net")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://www.libsdl.org/projects/SDL_net/release/"
+ "SDL2_net-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08cxc1bicmyk89kiks7izw1rlx5ng5n6xpy8fy0zxni3b9z8mkhm"))))
+ (propagated-inputs
+ (propagated-inputs-with-sdl2 sdl-net))))
+
(define-public sdl2-ttf
(package (inherit sdl-ttf)
(name "sdl2-ttf")
@@ -544,93 +559,3 @@ sound and device input (keyboards, joysticks, mice, etc.).")
The bindings are written in pure Scheme using Guile's foreign function
interface.")
(license lgpl3+)))
-
-(define-public ghc-sdl2
- (package
- (name "ghc-sdl2")
- (version "2.4.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/"
- "sdl2/sdl2-" version ".tar.gz"))
- (sha256
- (base32
- "0p4b12fmxps0sbnkqdfy0qw19s355yrkw7fgw6xz53wzq706k991"))))
- (build-system haskell-build-system)
- (arguments '(#:tests? #f)) ; tests require graphical environment
- (inputs
- `(("ghc-exceptions" ,ghc-exceptions)
- ("ghc-linear" ,ghc-linear)
- ("ghc-statevar" ,ghc-statevar)
- ("ghc-text" ,ghc-text)
- ("ghc-vector" ,ghc-vector)
- ("sdl2" ,sdl2)))
- (native-inputs
- `(("ghc-weigh" ,ghc-weigh)
- ("pkg-config" ,pkg-config)))
- (home-page "http://hackage.haskell.org/package/sdl2")
- (synopsis "High- and low-level bindings to the SDL library")
- (description
- "This package contains bindings to the SDL 2 library, in both high- and
-low-level forms. The @code{SDL} namespace contains high-level bindings, where
-enumerations are split into sum types, and we perform automatic
-error-checking. The @code{SDL.Raw} namespace contains an almost 1-1
-translation of the C API into Haskell FFI calls. As such, this does not
-contain sum types nor error checking. Thus this namespace is suitable for
-building your own abstraction over SDL, but is not recommended for day-to-day
-programming.")
- (license bsd-3)))
-
-(define-public ghc-sdl2-mixer
- (package
- (name "ghc-sdl2-mixer")
- (version "1.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/sdl2-mixer/"
- "sdl2-mixer-" version ".tar.gz"))
- (sha256
- (base32
- "1k8avyccq5l9z7bwxigim312yaancxl1sr3q6a96bcm7pnhiak0g"))))
- (build-system haskell-build-system)
- (inputs
- `(("ghc-data-default-class" ,ghc-data-default-class)
- ("ghc-lifted-base" ,ghc-lifted-base)
- ("ghc-monad-control" ,ghc-monad-control)
- ("ghc-sdl2" ,ghc-sdl2)
- ("ghc-vector" ,ghc-vector)
- ("sdl2-mixer" ,sdl2-mixer)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://hackage.haskell.org/package/sdl2-mixer")
- (synopsis "Bindings to SDL2 mixer")
- (description "This package provides Haskell bindings to
-@code{SDL2_mixer}.")
- (license bsd-3)))
-
-(define-public ghc-sdl2-image
- (package
- (name "ghc-sdl2-image")
- (version "2.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/sdl2-image/"
- "sdl2-image-" version ".tar.gz"))
- (sha256
- (base32
- "1pr6dkg73cy9z0w54lrkj9c5bhxj56nl92lxikjy8kz6nyr455rr"))))
- (build-system haskell-build-system)
- (inputs
- `(("ghc-sdl2" ,ghc-sdl2)
- ("ghc-text" ,ghc-text)
- ("sdl2-image" ,sdl2-image)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://hackage.haskell.org/package/sdl2-image")
- (synopsis "Bindings to SDL2_image")
- (description "This package provides Haskell bindings to
-@code{SDL2_image}.")
- (license expat)))