summaryrefslogtreecommitdiff
path: root/gnu/packages/sawfish.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/sawfish.scm')
-rw-r--r--gnu/packages/sawfish.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index ede725877d..8795d8d9fb 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -47,13 +47,6 @@
(base32
"1bmcjl1x1rdh514q9z3hzyjmjmwwwkziipjpjsl301bwmiwrd8a8"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- ;; The 0.92.6 tarball was not produced by 'make dist'
- ;; and lacks generated files. Sadness.
- (zero? (system* "autoreconf" "-vfi")))))))
(native-inputs
`(("makeinfo" ,texinfo)
("pkg-config" ,pkg-config)
@@ -94,10 +87,12 @@ implementing both small and large scale systems.")
"0qslm2isyv22hffdpw0nh7xk8jw8cj3h5y7d40c9h5r833w7j6sz"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile.in"
- (("installdir=\\$\\(repexecdir\\)")
- ;; Install libraries for librep to $out/lib/rep.
- "installdir=$(libdir)/rep")))))
+ '(begin
+ (substitute* "Makefile.in"
+ (("installdir=\\$\\(repexecdir\\)")
+ ;; Install libraries for librep to $out/lib/rep.
+ "installdir=$(libdir)/rep"))
+ #t))))
(build-system gnu-build-system)
(arguments '(#:tests? #f)) ; no tests
(native-inputs
@@ -134,7 +129,8 @@ backend of Sawfish.")
"REP_DL_LOAD_PATH=$(REP_DL_LOAD_PATH):"))
(substitute* "src/Makefile.in"
;; Install libraries for librep to $out/lib/rep.
- (("\\$\\(repexecdir\\)") "$(libdir)/rep"))))))
+ (("\\$\\(repexecdir\\)") "$(libdir)/rep"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests