summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index d10c6ebc9c..f4bd0e3f11 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -151,14 +152,14 @@ anywhere.")
(define-public samba
(package
(name "samba")
- (version "4.9.5")
+ (version "4.10.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
(base32
- "001p896z609vb0qs196bgl362j7y3qibgm5gcl9028lfv795d287"))))
+ "0n1ld77y8sydkpx6l8i2hqa1k7hpkr8df91pg849glc4b85407wz"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -225,7 +226,7 @@ anywhere.")
("xsltproc" ,libxslt) ;ditto
("perl" ,perl)
("pkg-config" ,pkg-config)
- ("python" ,python-2))) ; incompatible with Python 3
+ ("python" ,python)))
(home-page "https://www.samba.org/")
(synopsis
"The standard Windows interoperability suite of programs for GNU and Unix")
@@ -241,14 +242,14 @@ Desktops into Active Directory environments using the winbind daemon.")
(define-public talloc
(package
(name "talloc")
- (version "2.1.16")
+ (version "2.2.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/talloc/talloc-"
version ".tar.gz"))
(sha256
(base32
- "1aajda08yf7njgvg6r21ccxlvkarb9bwvf4jqh8yn3871a1zcnqr"))))
+ "1g1fqa37xkjp9lp6lrwxrbfgashcink769ll505zvcwnxx2nlvsw"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -308,14 +309,14 @@ destructors. It is the core memory allocator used in Samba.")
(define-public tevent
(package
(name "tevent")
- (version "0.9.39")
+ (version "0.10.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/tevent/tevent-"
version ".tar.gz"))
(sha256
(base32
- "1rnln76ngd2b8lgqvfa9iscy6jizwycj85nfp9zd46b1c760z3gn"))))
+ "1rm4d9245ya15wyrh9vqn1dnz14l2ic88mr46ykyc6kdrl99dwrk"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -344,14 +345,14 @@ many event types, including timers, signals, and the classic file descriptor eve
(define-public ldb
(package
(name "ldb")
- (version "1.6.2")
+ (version "1.6.3")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/ldb/ldb-"
version ".tar.gz"))
(sha256
(base32
- "1kiwlra6nfkb5n870k2db41jrm59bq9lxqmil4v7ignblgsdfdwb"))
+ "01livdy3g073bm6xnc8zqnqrxg53sw8q66d1903z62hd6g87whsa"))
(modules '((guix build utils)))
(snippet
'(begin