summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index da4f251ab6..c69345910b 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -153,14 +154,14 @@ anywhere.")
(define-public samba
(package
(name "samba")
- (version "4.10.6")
+ (version "4.11.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
(base32
- "0hpgdqlyczj98pkh2ldglvvnkrb1q541r3qikdvxq0qjvd9fpywy"))))
+ "174fwi8n191dnb8ix9afchfp59hic6iwa3062iz3y7zzmxs1rpva"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -225,6 +226,7 @@ anywhere.")
(native-inputs
`(("docbook-xsl" ,docbook-xsl) ;for generating manpages
("xsltproc" ,libxslt) ;ditto
+ ("rpcsvc-proto" ,rpcsvc-proto) ;for 'rpcgen'
("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python)))
@@ -243,14 +245,14 @@ Desktops into Active Directory environments using the winbind daemon.")
(define-public talloc
(package
(name "talloc")
- (version "2.2.0")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/talloc/talloc-"
version ".tar.gz"))
(sha256
(base32
- "1g1fqa37xkjp9lp6lrwxrbfgashcink769ll505zvcwnxx2nlvsw"))))
+ "1iigk4a7n9k9qqq0h3a5vah67ycpqzvahvdhzy15lm428jrvrmbm"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -310,14 +312,14 @@ destructors. It is the core memory allocator used in Samba.")
(define-public tevent
(package
(name "tevent")
- (version "0.10.0")
+ (version "0.10.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/tevent/tevent-"
version ".tar.gz"))
(sha256
(base32
- "1rm4d9245ya15wyrh9vqn1dnz14l2ic88mr46ykyc6kdrl99dwrk"))))
+ "1dhhd7fz6wyvlwrk1a6gj5m2mcjsc3ilx0mcv1qsr1lbndldm93r"))))
(build-system gnu-build-system)
(arguments
'(#:phases