summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index e1c32dbe10..74de6f3ae1 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -411,6 +411,8 @@ test = { path = \"../libtest\" }
"output/rustc-build/rustc"
"-C" (string-append "linker="
(getenv "CC"))
+ ;; Required for libterm.
+ "-Z" "force-unstable-if-unmarked"
"-L" "output/target-libs"
(string-append "src/" name "/lib.rs")
"-o"
@@ -430,7 +432,13 @@ test = { path = \"../libtest\" }
("libpanic_unwind")
;; Uses "cc" to link.
("libstd" "-l" "dl" "-l" "rt" "-l" "pthread")
- ("libarena")))
+ ("libarena")
+
+ ;; Test dependencies:
+
+ ("libgetopts")
+ ("libterm")
+ ("libtest")))
#t)))
;; This phase is overridden by newer versions.
(replace 'check